: 94 STS with cruise & idle problem. Please help



94 STS
09-24-04, 02:51 PM
Hey,

I am experiencing uneven idle and the cruise is acting very erractically. Sometimes the rpm's will go back and forth between 600-1100. Seems like it is affected more when the a/c is on. The car has plenty of power and is getting good gas mileage.
The code that I am getting is P065. No other codes are appearing. The car is a 94 STS with 227k miles on it. Any help would be greatly appreciated.

Thanks,
Kelly

rollman
09-24-04, 06:23 PM
P065 .................................................. ....... Cruise - SPS Failure

According to the code thats the problem . However I'm not familiar with the problem but somebody will enlighten us both . Good luck

BTW you have some miles on that caddy. My 94 is about to hit 100,000 and I hate the thought but I dont feel so bad now. :D

caddyshack24
09-24-04, 07:23 PM
Seriously, I'm nearing the 100k mark and was a little worrried. Love to hear your milage.

P065 -- Cruise Control Servo Position FailureThe cruise control servo is a variable inductance sensor whose inductance changes with servo posistion.. P065 Sets when the PCM detects a low servo posistion signal indicating an open or short in the cruise control servo position sensor.

Disables cruise control.

My take on it:
You'll prolly want to replace that sensor. heh

I can walk you threw the diagnostics, cuz unfortuantly i dont have a scanner.
you'd start by going to PCM Data 70 (PD70) (C/C Feedback)
and noting the value..

Eldyfig
09-24-04, 07:32 PM
That code most likely will explain your cruise control problem. However, it isn't going to cause a problem at idle. I recently had a problem similar to the one you are having now. One of my coil packs was giving out. An easy test to do is a cylinder balance check. In your OBDI, go to PCM Overrides, scroll to PS04. The PCM will raise the idle rpms up to run the test. The selected cylinder number will be displayed in the a/c temp display area. Press the cooler button to disable the cylinder shown. Press the warmer button to scroll to the next cylinder. Listen carefully. When you disable a cylinder, you should here a slight change in sound from the engine. If you do not hear a sound change or it is weak, check the opposing cylinder that is on the same coil pack. Weak or no sound on that cylinder also and you have a bad coil.

caddyshack24
09-25-04, 09:04 AM
What about if the cuise control servo still has vaccum applied, wouldnt that cause an idle problem?

You could enter diagnostics and PCM Override 07 (PS07) (C/C Servo Position)
and press the 'cooler' button. will release all vaccum. If it fixes your idle. great.

It could be the wiring, the sensor or the servo itself. When you drive though, the vaccum is going to be re-applied to pick up the slack in the line.

94 STS
09-26-04, 04:10 PM
Thanks,

I'll post whatever happens.
Thanks for all of your responses.

Kelly