: Need Help!! 2002 Escalade!!!



CTSLack941
12-28-10, 08:57 PM
Just bought 2002 Escalade 2 days ago and everything worked great. I accidently left the interior lights on last night and of course the next day the battery was dead. Charged it and everything seemed fine. Anyways, I noticed today now only my heat and ac will only blow through my defrost vents! Im not sure if the battery dying had anything to do it with it or if something broke, I did hear a weird noise in the dash, but it went away. You turn the knob in all directions and it does nothing, it only blows through the defrost vents. Anyone have any ideas or ever have this problem? Thanks, Matt

bstiffmanofsteel
12-28-10, 11:26 PM
Try disconnecting the negative terminal and leaving it off for a few minutes. See if that resets your system.

mosimann
12-29-10, 02:59 AM
I had a bad connection on the battery terminals of my service van and had two problems. Low beams were dimmer and the fan was blowing much weaker. Like speed 4 blowing like 3. Charged the battery and drove a couple hours to make sure it was back 100% charged again. Problems solved.

gmercedesbenz
12-29-10, 10:49 AM
Sounds like the auto climate got out of sync when you had to recharge your battery. I would try the "unplug and plug it back in" fix, just disconnect the battery for 10-15 minutes, and reconnect. This will reset everything in the truck and hopefully fix your problem. Just out of curiosity, which interior lights did you leave on? I know that if you leave the reading lights on, the truck will automatically shut them off after 20 minutes to avoid running down the battery.

CTSLack941
12-30-10, 11:41 AM
I left the interior dome lights on.. I accidently pushed the rolling switch all the way up, so the dome lights would stay on all the time. I tried unplugging the battery and reconnecting, but im not sure how long I left it unplugged? Maybe 10 mins I would guess. I tried pulling certain fuses and then popping back in, still no luck... Any idea's???