: Newbie - cup holder and tail light problems



Gep69
12-23-10, 10:38 AM
Hi all,
I just bought a 2005 ESV Platinum and am having a couple of issues.

1. Passenger side rear tail light went out. Both bulbs, which I thought was weird that they both went at the same time and figured it was going to be more than just the bulbs. Brake lights come on when pressed.
Replaced both bulbs, one visibly needed changing. Still same issue.
Any help here?

2. Driver side cup holder heater.
Sometimes it comes on sometimes it doesn't. Sometimes I press the button and the light comes on for a second and goes off. Sometimes I press the button and the light comes on but it doesn't heat up. Sometimes it works great.
Any help would be apperciated.

I've done some searching but didn't come up with anything really useful.

Thanks.

Gep69
12-31-10, 12:27 PM
bump- Anyone have any suggestions?

sk7
01-01-11, 09:11 AM
Have a look at the junction block for the rear lights. Its located in the inner rear wheelwell passenger side. Its often the source of problems (corroded connectors, lack of 12V and ground).

Gep69
01-01-11, 09:20 PM
Thanks for the heads up.
I will give that a try.

Gep69
08-02-11, 01:04 PM
I figured I would post with what the solution was for my tail light problem.
I finally pulled the wiring harness out from behind the tail light and found one wire had broken and one that was rubbed bare and was grounding out.
I thought this was kinda strange because its in a protected part of the car inside the wheel well behind the tail light.
Cadillac wanted almost three hundred dollars for the whole tail light and harness, wouldn't just sell the harness. I fixed it for five bucks in solder and heat shrink tube.