: Thumping noise from front suspension on wavy road!!



nahc
12-15-10, 11:22 PM
Anybody else have this? Whenever you drive between 5mph and 20mph on an uneven road or over a small bump. I wonder if it's particular to fwd models. It happened on my 2010 srx and is starting to happen on my 2011 srx.

sube5186
12-15-10, 11:36 PM
Did you already take possession of the 2011 replacement SRX, or are you still in the testing phase?


Sube

stevec5375
12-16-10, 08:33 AM
Does anybody ever bother to read or search the other threads before posting a new one? This is currently being discussed at length in another thread. :)

See here: http://www.cadillacforums.com/forums/cadillac-srx-second-generation-forum-2010/215799-roaring-rubbing-sound-when-its-cold.html

Ponyman
12-16-10, 09:12 AM
Haven't experienced this problem, or any other major problem on ours.

SWATBOY
12-16-10, 12:32 PM
Yes, mine does the same thing. My dealer is replacing the left rear shock tomorrow in an attempt to fix the problem.

nahc
12-16-10, 02:39 PM
Did you already take possession of the 2011 replacement SRX, or are you still in the testing phase?


Sube
I am still in the testing phase. They gave me one week to test it.

nahc
12-16-10, 02:43 PM
Does anybody ever bother to read or search the other threads before posting a new one? This is currently being discussed at length in another thread. :)

See here: http://www.cadillacforums.com/forums/cadillac-srx-second-generation-forum-2010/215799-roaring-rubbing-sound-when-its-cold.html
This is a totally different issue. It has nothing to do with a rubbing noise or the temperature outside.