: 2005 STS XM Radio lost



mmcubed
12-10-10, 04:20 PM
I have a 2005 STS and all of a sudden XM is no longer available as a band on the radio. The AM, FM1 and FM2 are still there but XM1 and XM2 are gone. Called my dealer and they said it was a subscription problem but XM tech says subscription is fine and is a radio/auto problem. Anybody have similar problem or any advide?

rzambrano
12-10-10, 06:01 PM
Never heard of such a thing. One thing I can advice (it was told to me for a different Nav problem), go into the fuse box in the right rear seat, remove the Nav's fuse for like 5 minutes, put it back in, and that might help.

EChas3
12-11-10, 12:54 AM
I remember a thread from a long while back... in my memory exactly the same. I don't recall if the 'reset' trick worked but there's little harm in trying.

Remove negative battery cable, remove positive cable & touch them together for a few seconds. Connect positive & then negative. You may need to retrain the express-up windows.

Somebody did have the XM module go bad. Trunk?

M.A.C
12-11-10, 12:58 AM
I have an 05 STS and though I don't have a subscription, I can still tune in to promotional XM. Also, I have no idea what you mean by FM1 and FM2. There is only one FM. I get AM, FM, XM, and WX weather stations.

EChas3
12-11-10, 04:38 PM
I have an 05 STS and though I don't have a subscription, I can still tune in to promotional XM. Also, I have no idea what you mean by FM1 and FM2. There is only one FM. I get AM, FM, XM, and WX weather stations.

He is confused by the display. There's only 1 FM. If you're on FM, the current source looks like another FM button.

carter's_sts
12-12-10, 12:24 AM
Try switching to the other driver in the menu and then back. That worked for me. If not try the battery reset.