: I've got a list. 89 Brougham



FreshPaint
12-09-10, 11:25 PM
It's time to play... What is wrong with Mikes Caddi.

first of all, and this bothers me. My turn signal light stays on. On both sides... I've checked all lights and both flashers. It worked (to my excitement) for 2 days afte changing my speedo cable, but I gave my cursed friend (he breaks cars without even touching them) a ride and it stopped working again.

Next, is it possible for water to leak from the timing cover? I'm sure I have a blown timing cover gasket, we just changed the water pump and it seemed reasonable. Can it get bad if I choose to procrastinate on changing it ? I need my car daily and don't have much time to devote to it.

Next, when I put the car in drive, or reverse. It clunks, and jerks forward or backwards.

Number 4, half the time when starting the car it makes a buzz like sound. I sit there a little longer and prime it and keeping trying till it cranks like it should.

Number 5, how can I find out if it has a security system. I noticed it has a light for it on the dash, and I have a sticker from denton auto alarms and tints on the window.

I've got more but this will hold me for now.

cadillac kevin
12-09-10, 11:45 PM
with the security system, does the light ever light up, and do either of the yellow or green dots next to it ever light up? it sounds like an aftermarket system might have been installed and the installer put a lightbulb in the dash for the alarm on light.

sven914
12-10-10, 12:20 AM
With your turn signals, if you mean that only the indicator lights in the instrument cluster are on, then the blue wires that feed them may be shorted to voltage. If your mean that all of the lights on the outside of the car and the indicators in the dash are constantly flashing, then your Hazard-Flasher may be shorted to voltage. If your mean that all of the lights on the outside of the car and the indicators in the dash are on constant (no flashing), then something is seriously messed up in your wiring. If you mean the outside lights are on constantly but the dash lights are off, then check the light switch to verify it is not in the Park position.

As for the timing cover; I do not believe there is a coolant passage behind that. The timing cover would be leaking oil if the gasket was bad. I recently had a bad leak, which I thought was the pump, and it turned out to be a bad seal on the thermostat housing.

Your issues with the transmission could possibly be your idle being set too high. If you do not already do so, you need to kick the idle down and disengage to fast idle cam 30 seconds after a cold start. The clunking sound could be backlash in the differential, cause by gaps between the ring and pinion gears. Also, on these cars, reverse does not engage immediately (it sits in neutral for a few seconds), so if you get into the throttle as soon as you shift, you are going to cause a harsh engagement.

You need to better define the buzzing sound. Does it the starter just click or will the engine try to turn over? Being that this is a carburetted engine, you need to pump the throttle with every cold start, but the engine will try to start either way.

To test you security system, roll down your window, lock the door, get out of the car, pull the lock rod up, and open the door. If the factory security system is functional you will need to close the door, lock it, then unlock it with the factory door key. An after market alarm system may differ in disabling technique.


with the security system, does the light ever light up, and do either of the yellow or green dots next to it ever light up? it sounds like an aftermarket system might have been installed and the installer put a lightbulb in the dash for the alarm on light.

The yellow (amber) and green dots are not apart of the factory security system. They are apart of the Fuel Economy Monitoring system, available for 1980.

FreshPaint
12-10-10, 03:52 PM
It's not that the ligts are constantly flashing. The problem is when I use the turn signal none of them flash at all... The light stays solid.

I lowered the idle on it and it doesn't clunk anymore. Thank you

and the water appears around the back of the timing cover. Or atleast the top from what I can see. I'm not sure if it's leaking oil aswell. I recently changed a valve cover gasket so the engine is caked in oil.

I'll try to post a video tonight

outsider
12-10-10, 05:15 PM
check the blinker bulbs. my 87 did the same thing when the blinker bulb was bad.

sven914
12-10-10, 05:51 PM
If the bulbs are good, then the Turn-Hazard switch, is probably not working.

FreshPaint
12-16-10, 09:24 PM
good news everybody!

Turns out there is a flasher next to the steering column for the turn signals

now I'm down to the buzzing on cold starts and leaking water

I have a video but I just need to get to a computer (ive been posting on my palm pre)