: Fixed my non-working Heated Seats *How-to w/ Pics*



CoupeDTS
11-19-10, 11:25 PM
My passenger heated seat never worked in my 96 Caddy FWB and I could find NO information on any sites on how to fix it so I gave it a shot myself.

First understand how they work. There is a switch on the seat that goes under the seat to a relay box that you can hear click when set on Hi or Low. The relay box gets power from the main power hookup under the seat. Power is then sent out to the Back rest heating element and the seat bottom element. The elements are made up of weaving wires that are underneath a glued down pad.

http://img28.imageshack.us/img28/1866/1119001540b.jpg

Here is the relay box removed from the seat. I took this apart and found a little corosion on the contacts for the relay. This wasnt the problem why mine didnt work but it could be for other people. Also good maintenance I guess

Since my relays were working the next thing to test is the elements themselves. Instead of tearing the seats apart you can test the elements with an ohm meter.

http://img405.imageshack.us/img405/9864/1119001540.jpg

The black hanging plug is the plug from the seat back element. It has 2 wires. Set your ohm meter to 200 and touch it to both leads. It should be around 1 ohm. Could be 1.1 or 1.5, the elements themselves say .95 ohms so anything around that means there is no break in it. If there is a break in the elements wire somewhere it will just read the infinate reading.

http://img258.imageshack.us/img258/7894/1119001540a.jpg

These are the 2 wires that come from the bottom element. 1 had 2 wires and 1 has 4 wires. The plug with 4 wires put your multimeter end to the red wire and to one of the other wires on the 2 wire plug to test.

In my instance it was the bottom element that didnt have a reading. My seat back read 1.1. The bottom leather was pretty easy to release compared to the seat back. OF COURSE DO ALL THIS WITH THE SEAT OUTSIDE OF THE CAR!

http://img600.imageshack.us/img600/1608/1119001507.jpg

Examining the element with the leather off I found a burnt spot. Obviously this is where the break was.

Instead of searching for a replacement I decided to try to repair it.

http://img545.imageshack.us/img545/4655/1119001509.jpg

Turns out the wire is stranded copper wire with a hard jacket around it. This means it can be soldered easily. In the picture you can see the wire I stripped. MAKE SURE WHEN STRIPPING THE WIRE TO NOT CUT ANY STRANDS OF THE WIRE! This will weaken the wire and cause another burnout. Slowly strip away the insulation.

http://img207.imageshack.us/img207/8955/1119001520.jpg

I used similar wire for the patch. Dont use anything smaller! Here you can see the patch.

http://img33.imageshack.us/img33/8/1119001542.jpg

To keep the cover back down over the element I used some gorilla tape. Glue might work also. I wouldnt use duct tape on stuff that heats up.

After the repair you can test the resistance again and see if it is fixed. Plug it all back in. Assemble the seat and enjoy heat again :thumbsup:

csbuckn
11-20-10, 12:05 AM
Nice write up, I didnt know the 96s come with heated seats. I'll have to add them to my wish list.

outsider
11-20-10, 07:56 AM
nice man! I'll have to look into this. my driver's heated seat is no worky :(

thefleetwoodguy
11-20-10, 12:07 PM
great post !!

CoupeDTS
10-16-11, 03:19 AM
TTT for winter :)

Rick James
10-19-11, 01:14 PM
Thanks for the knowledge.