: Trunk Emblem Came Off!!!!



sven914
11-13-10, 04:58 PM
http://img219.imageshack.us/img219/857/194043224560860472.jpg

http://img219.imageshack.us/img219/2765/19404322462429029.jpg

http://img219.imageshack.us/img219/4773/194043224777896217.jpg

I was getting something out of the trunk, and was opening the face. Just before the face reached the point where it locks, then entire emblem swung around and fell off in my hand.

What do I do? It looks like the rivets sheared off and are still in the emblem. My service manual says to drill out the rivets, and replace them with the emblem. Has any one done this? If so, where do you get the rivets and how hard is it to re-install them?

csbuckn
11-13-10, 05:25 PM
When I got my car, it didnt have a crest or badge. The rivets in the trunk lid were gone and there were just holes, the replacement badge had holes where the rivets are too. I just found some screws/bolts(dont remember) that threaded into the hole(dont remember if it threaded into the badge or lid) and screwed it on. I'll be able to look later.

sven914
11-13-10, 05:34 PM
Do you remember the dimensions of the screws (length, width, and fineness of the threads)?

csbuckn
11-13-10, 09:01 PM
No, I don't remember. I wanna say its a machine screw but I wont be able to look til late night.

Angry Matt
11-13-10, 10:00 PM
I drilled mine and used a rivet gun. It took a few tries but came out great in the end. It's not hard, you just have to figure out the right size to hold it tight and get a tip on the rivet gun that will fit into the small hole in the emblem. Rivets are soft and they drill out fairly easy, just don't make the holes any bigger than they already are.

caddeville89
11-14-10, 06:40 PM
I stuck mine back on with emblem goop. Is holding pretty well so far.

mjs182004
11-14-10, 11:39 PM
You could use 3M double sided foam tape meant for molding. that is what i used to reattach the crest for mine. Although it doesn't look like there is enough surface to do that with.

http://i161.photobucket.com/albums/t201/mjs182004/1991%20Cadillac%20Brougham/15-1.jpg

http://i161.photobucket.com/albums/t201/mjs182004/1991%20Cadillac%20Brougham/16-1.jpg

http://i161.photobucket.com/albums/t201/mjs182004/1991%20Cadillac%20Brougham/17-1.jpg

http://i161.photobucket.com/albums/t201/mjs182004/1991%20Cadillac%20Brougham/18-1.jpg

1980coupe
11-15-10, 12:25 AM
i drilled out rivets and I used screws to secure new one back on. i had some screws laying around and used those and to this day; it's been holding on fine.

sven914
11-15-10, 05:06 PM
I've been trying to drill out the rivets, but the bit won't bite into it. It seems like the center is too hard and my drill just dances around it instead of cutting into it. I'm going to try to file the rivets flush and see if a flatter surface helps. I got the head of the rivet out of the base of the emblem.

1980coupe
11-16-10, 12:44 AM
I've been trying to drill out the rivets, but the bit won't bite into it. It seems like the center is too hard and my drill just dances around it instead of cutting into it. I'm going to try to file the rivets flush and see if a flatter surface helps. I got the head of the rivet out of the base of the emblem.

maybe you're not using the correct drill bit. I had no problems with the removal of mine.
How's the economy indicators coming out; did you get the light to lit up? I left my alone as now it's working fine.

sven914
11-16-10, 08:12 PM
^I still need to re-run that wire, but the indicator comes on occasionally...

I got the rivets out; had to use a center punch. How long do the screws need to be?

sven914
11-17-10, 09:34 PM
I got it mounted. Used #10 1-1/2 screws, but had to file the heads down to make them sit flush with lip on the emblem, so that the face will close.
http://img530.imageshack.us/img530/4434/194043544710712145.jpg