: 69 coupe deville 472 KNOCKING NOISE?!?!?!



killacam
11-10-10, 06:07 PM
I HAVE 69 DEVILLE with the stock 472. a little under 100,000 miles and once up to temperature there is a knocking, clicking noise coming from the motor. BUT ONLY AT IDLE OR LOW RPMS. when in gear, it goes away around 2500 rpms but everything under that its there. but, when in neutral it stays no matter what rpm its at. my mechanic already checked all rockers, lifters, oil pressure, oil pump, torque converter etc. theres no visible carbon buildup anywhere so i know its not on th epistons either...can ANYONE help me????

csbuckn
11-10-10, 08:20 PM
Someone here had the same problem a while ago, it was the oil pump getting weak. It's external so its very easy to replace. The piece that the oil filter connects to.

killacam
11-15-10, 06:55 PM
already replaced that, along with new oil pan(because of sludge and it being dented from hitting bumps)..oil pressure is perfect...any other ideas????

csbuckn
11-15-10, 07:03 PM
Cracked flywheel?

jayoldschool
11-15-10, 09:02 PM
already replaced that, along with new oil pan(because of sludge and it being dented from hitting bumps).

Main bearings wearing out, opening up tolerances, due to previous oil starvation from the sludge/pump sucking against the pan. Knock goes away at higher RPMs with increased oil volume/pressure. Get some thicker oil in there ASAP. 20w50.

Dirtywaterdiver
11-16-10, 12:03 AM
Check the SMOG pump. I had a noise that sounded like a bottom end problem.

When changing the belts over I spun the SMOG pump pulley, same noise I heard so I am looking forward to replacing it.

Worth a check.