: 2005 STS no Nav./with Bose, on-star wire hook-up!



cadillac48170
11-08-10, 08:10 PM
Hi people, I just bought an 05 STS with no nav. and my on-star comes on, but won't make a connection. I hit the "Blue" On-Star button, says "connecting to On-Star" beeps 5-6 times then says "unable to connect to On-Star". I've also hit the "Red" button and it says the same thing. I took the face plate off and removed the radio and all the wires "look" right, but I'm not sure. What esle can I check. Please help! My radio is a UX8, if that helps.

mike sts
11-08-10, 08:37 PM
your car may not have had the digital on star upgrade. Does the button all the way to the left of the rear view say auto ie turns auto high beams on and off or is it a on/off symbol. If it has auto button then you probably have digital if not go to dealer pay 200.00 they will upgrade car to digital 200 includes ist year of onstar.

cadillac48170
11-08-10, 08:47 PM
It does not have the Auto on the mirror, just the pwr switch. Is the upgrade a new mirror assembly?

mike sts
11-09-10, 07:44 PM
The upgrade is a new vcim(onstar box), a new antena and a new mirror. If you have the nav with bluetooth the new mic in the mirror is not magneticaly shielded which means if you have a GSM phone people may hear a buzzing noise when you call them.

mike sts
11-09-10, 07:46 PM
Oh I notice you dont have the nav so for bluetooth you would have to talk the dealer into installing a even newer onstar module that has bluetooth built into it, it would be very hard to get them to do it cause it would be the wrong part number for the car and its a restricted part.