: Radio and Nav screen still playing after you shut off the ignition



Hockeytown 1340
11-07-10, 12:06 PM
Just curious if anyone had a problem with the radio and Nav screen still up and running after you shut off the engine, exit the vehicle and lock your doors?

On two occasions as I walked away from the vehicle I noticed the above. I didn't want the battery to drain down while everything was still running! To fix it, I had to repeat the process, unlock the doors, re-start the engine, shut off the engine and then the Nav screen went down and the radio shut off like it should. Dealer couldn't find anything wrong with it. It's only happened twice in 7 months.

stevec5375
11-07-10, 12:39 PM
Just curious if anyone had a problem with the radio and Nav screen still up and running after you shut off the engine, exit the vehicle and lock your doors?

On two occasions as I walked away from the vehicle I noticed the above. I didn't want the battery to drain down while everything was still running! To fix it, I had to repeat the process, unlock the doors, re-start the engine, shut off the engine and then the Nav screen went down and the radio shut off like it should. Dealer couldn't find anything wrong with it. It's only happened twice in 7 months.

Do you have anything heavy lying in a seat that might trick the car into thinking someone is still present inside? I don't know if that could cause it but it might be a possibility.

Hockeytown 1340
11-07-10, 09:01 PM
Nothing was left on the seats, but thanks for asking.

davdat
11-08-10, 02:29 AM
I had it happen once, the reason it did it was I actualy pressed the ignition switch a second time just for a slight second and it made the screen stay up the SRX thought I was going to not exit and wanted it to stay in assery mode. I had to unlock the doors and press it again, the screen and radio shut off. You may have inadvertantly double pressed the ignition button. I still love my SRX she's sweet!