: 1987 allante power steering presure switch? e040 code



flshgear
10-25-10, 08:11 PM
i just got this car. the check engine light keeps coming on. i checked the codes and the only one is e040, power steering presure switch. i am trying to search online about this and i cant find anything. the only thing i find is about a 93 allante presure switch, part # pss12. but i cant find anything on an 87.

the car while going slow, like parking or doing a u turn is very hard to steer. at higher speeds the car is fine.

the previous owner said that the check engine light always came on, for 2-3 years. he had a piece of electrical tape over the check engine light. he said not to worry about it, but i would like to fix it.

i checked alldata as well but there is limited info on that. it says how to check the switch with a multi meter. and other trouble shooting, if mulitiple codes come up with the e040 code. there is no part number or location or pictures.

does any one know anything about this? what is the part number i need, and interchangeability of that part with other more common cars.

the fluid level is good in the resivior.

billc83
10-26-10, 12:42 AM
Is it an intermittent problem? I have an '88 and my car will pop up E040 occassionally, but I have never had any problem with steering.

carnut
10-26-10, 10:19 AM
This switch is located in the steering rack where the column connects to it. Look closely below the brake master cyl. straight down. It looks like an oil pressure sender on an engine. The harness to it comes loose or becomes corroded over the years causing false failure messages on the DIC. My 88 did this. Its job is to send a signal to the computer to raise the idle speed when the wheel is turned. I cleaned the connector pins with brakleen applied dielectric grease to the pins and reinstalled the connector. If the sensor is faulty I think its shared with the Eldo and Seville regarding part number. Its operation can be monitored thru the DIC where it will show a series of pressure readings as the wheel is turned. My readings would drop to zero ( open connection) at times, hence the E040 code.

flshgear
10-27-10, 06:56 PM
it is an intermintant thing. i was checking out the dic and watching the readings and it would drop to zero and then the lcheck engine light would come on.

i will check the conection and try cleaning it.
thanks

Trulytex
12-13-10, 11:41 PM
How did the issue turn out? I have the same problem with my 87. No error code, but my power steering is very hard when sitting still or at very slow speed.