: CADDYESCALADE ) 02...Brakes???



chirochris
10-17-10, 12:49 PM
when I press on the brakes ...when coming to a complete stop, NOT when driving at fast speeds......it feels like it is slipping and I feel it in the brake pedal than it catches and and it almost needs to be pumped by me to stop.
also makes a slipping noise........anyone know what this could be cause the pads and rotors are ok

Thank you in advance!!! new caddi owner and appreciate the help

sk7
10-17-10, 07:10 PM
I see new front bearings in your future! The sensors for the ABS are built into the bearings, and rust inside the toothed wheel sends false data to the EBCM which translates into wheel slipping. This activates the ABS when not needed and makes for scary, longer stops! You can deactivate the ABS for a bit to see if that takes care of the problem. Fuse (Maxi) underhood fusebox.

chirochris
10-24-10, 11:25 AM
thanks...gonna try that ,Il get back to you and appreciate the help

chirochris
10-24-10, 08:55 PM
If I did need to replace the bearings how much would they run about???
Im gonna try to disconnect the fuse tomorrow, and see if the problem stops.


Thanks again for the help......

Gale Hawkins
10-24-10, 09:44 PM
http://www.jcwhitney.com/wheel-bearings-and-hubs/cadillac-escalade-2002/c3843d222y2002j1s23.jcwx?_requestid=8804998

There are lower quality options too.

Note: These may not be for your car because I am not sure if they are for 2WD or AWD?

RippyPartsDept
10-24-10, 09:51 PM
If you get me your VIN (full or last 8 digits) i can check on the hubs for you, if it is indeed the abs sensors causing this
I can sometimes get really good deals on hubs/bearings (on top of the already good deal i would normally be able to get you)
PM, post it here, email or call (during business hours... info in my sig)

sk7
10-24-10, 10:27 PM
One member here replaced his front hubs with cheaper aftermarket units. Did one first, ABS signal didnt quite match the other side, so he replaced that one too, and in the end both signals did not agree with the EBCM and he had to get both front hubs replaced with OEM parts to finally get rid of the problem. If you really want your ABS to work top shape, stick with OEM parts. Maybe the EBCM can be reprogrammed for different kind of hubs?