: coolant leaks out end of new hose while clamped on pump and radiator.......?



H-Dmechanic
10-12-10, 09:29 AM
is there any tricks to stop this. it seems rediculous but i just replaced the upper radiator hose and the clamps are 100% tight, yet its leaking coolant out of the end of the hose between the nipple and inside diameter of the hose. what about rtv, pipe dope, duct tape...anything? never in my life have i delt with such a testy vehicle as far as reapairing it.

Submariner409
10-12-10, 11:51 AM
is there any tricks to stop this. it seems rediculous but i just replaced the upper radiator hose and the clamps are 100% tight, yet its leaking coolant out of the end of the hose between the nipple and inside diameter of the hose. what about rtv, pipe dope, duct tape...anything? never in my life have i delt with such a testy vehicle as far as reapairing it.

??? Wrong hose, bad clamps, or a lot of corrosion on the nipples. Don't use tapes or goop - do the job correctly.

Any chance that the (aftermarket ??) hose has an inner spring and it's interfering with the closure ?

johnny kannapo
10-12-10, 12:42 PM
You have either cracked the radiator nipple, have a badly corroded coolant pump thermostat/housing. It would be a extreamly remote chance the new hose is defective.

H-Dmechanic
10-12-10, 01:10 PM
nope theres no wire in this one. the clamps are brand new. i torqued them down a little further and it seems ok. got a pressure tester on it now. ive lost 3 psi in an hr. i have confirmed with the co2 test theres not a head gasket leak. just tryn to get this dang thing sealed up for good