: 93 sts w/97 n. s. fuel pump problem



chuck jenkins
09-15-04, 12:15 PM
I installed a 97 low milage (14,000) N.S. in my 93 sts and I have to wind it up in the mornings to get it to start. It starts good all day but I can hear the fuel pump running all the time. Help

BeelzeBob
09-15-04, 02:20 PM
Have you checked fuel pressure with a fuel pressure gauge installed on teh schraeder valve fitting on the fuel rail while cranking cold to see if it is maintaining a constant pressure.??

florida33779
10-13-04, 06:42 PM
Did you have any problems with the mass air flow sensor and if so how did you fix it. I have a 94 and just had a 97 motor installed and I have erratic idle problems I hear there is a fix but nobody can say where to get it.

chuck jenkins
10-13-04, 11:32 PM
I used the 93 throttle body (with no maf) with a spacer on the 97 intake. All 93 wiring harness and transmission. The 97 engine is a 275 hp engine but I can't see much difference in performance. I have not checked the fuel pressure yet. I need to buy a gauge and check it.

chuck jenkins
10-13-04, 11:43 PM
I used the 93 throttle body (with no maf) with a spacer on the 97 intake. All 93 wiring harness and transmission. The 97 engine is a 275 hp engine but I can't see much difference in performance. I have not checked the fuel pressure yet. I need to buy a gauge and check it. Hey florida33779 I'm florida33037 key largo. Where are you?

florida33779
10-14-04, 12:23 AM
I was in New Port Richey Florida but now I'm up in Ohio. I'm sure going to miss the nice Florida winters.