: Radio Power Problems



jimallyn
08-31-10, 05:17 PM
When I bought my SRX the radio worked like every other car I have owned. If the radio was powered "on" when you turned the car off then it would come back "on" when you started the car an hour or so later (after the car had powered down). In the last couple of weeks I have to push the power button to turn the radio "on" every time I start the car (after the car has powered down). I have had it into the dealer 3 times and they say that is the way it is supposed to work but I am skeptical. It didn't use to work that way nor has any other car I am aware of work that way. Has anyone else experienced this problem or is it just me. They recently did a software update which they said would fix the issues with the radio but nothing has changed.

stevec5375
08-31-10, 05:43 PM
When I bought my SRX the radio worked like every other car I have owned. If the radio was powered "on" when you turned the car off then it would come back "on" when you started the car an hour or so later (after the car had powered down). In the last couple of weeks I have to push the power button to turn the radio "on" every time I start the car (after the car has powered down). I have had it into the dealer 3 times and they say that is the way it is supposed to work but I am skeptical. It didn't use to work that way nor has any other car I am aware of work that way. Has anyone else experienced this problem or is it just me. They recently did a software update which they said would fix the issues with the radio but nothing has changed.


See this thread: http://www.cadillacforums.com/forums/cadillac-srx-second-generation-forum-2010/204438-last-played-favorites-remembered-after-shutdown.html

russellsmtry
03-04-13, 08:16 PM
When I bought my SRX the radio worked like every other car I have owned. If the radio was powered "on" when you turned the car off then it would come back "on" when you started the car an hour or so later (after the car had powered down). In the last couple of weeks I have to push the power button to turn the radio "on" every time I start the car (after the car has powered down). I have had it into the dealer 3 times and they say that is the way it is supposed to work but I am skeptical. It didn't use to work that way nor has any other car I am aware of work that way. Has anyone else experienced this problem or is it just me. They recently did a software update which they said would fix the issues with the radio but nothing has changed.

I have been having the same problem with my 2010 radio actually goes on when the car starts but cuts out in about 15 sec. also the clock will not stay set and the year keeps going back to 2006 and always says that I am in washington, DC
Mine is at the dealers now they just called and said they got it fixed. They said they had to completely erase the brain in the system and install a new brain. They said it is working fine now we will find out when I pick it up in the morning.

Cadillac Cust Svc
03-05-13, 02:06 PM
Jimallyn (if you're still reading this) board, have you contacted our Cadillac Customer Assistance Center yet regarding this frustration? If you would like me to look into this matter further for you, please don't hesitate to email me at Katie_Lucille@gmexpert.com.

Russellsmtry, I hope you will keep us updated once your SRX returns home from the dealer. Thank you for sharing your feedback so far!

Best,

Katie
Cadillac Customer Service

mtemple
03-19-13, 07:59 PM
I have this EXACT problem along with some others. It has begun losing the last station I listened to and always starts with FAV 1 when I start. I also see in the navigation system that I am in Washington DC no matter what I enter. I also have deleted all saved destinations and it acknowledges this and delets them. But the next time I restart the car, they are all there again. It will also not retain the proper digital clock setting once I shut down. Blue tooth is flaky as a $3 bill as often I cannot answer calls.

But the worst of it is that the air conditioning now only comes on in the passenger side. I have yet to take this back to the dealer, but I intend to and I hope for a good experience.

davedogcaddy
03-19-13, 09:40 PM
Well documented issue. Dealer will want to try to install latest USB software update for the radio (version U415). This doesn't usually fix it though. Usually the radio will have to be replaced. Had this done about a month ago. Solved all the issues you described.