: Clicking noise in 3.6



73survivor
08-25-10, 11:18 AM
I am looking to buy a 2008 STS AWD with the 3.6 engine. When I started it up at the dealership there is a ticking noise coming from the engine. As the engine warms up it gets quieter but it is still there. I was told that this is the normal operation of the high pressure fuel pump and injectors. The car has only 20k miles on it. Is this ticking sound something to be concerned about? Will it get worse as more miles are put on it? Has there been problems with the fuel pumps or injectors? I want to buy a good car. Anyone have any experience with this issue? TIA

briggy
09-11-10, 11:16 PM
hard to say, Has the car always done this or is this something new, and is it getting progressively worse.

tonyfort
11-09-10, 04:41 PM
If we are talking about the 3.6 Direct Injection engine then yes; the ticking is a normal sound of the direct injection system (though the DI ticking certainly does make it tough to determine if the engine itself does in fact have a different ticking noise that is actually a problem...)

anfpak
07-06-12, 08:07 PM
I know this is an old thread, but i didnt want to start a new one with the same question. Mine is a 2007 3.6L and is doing the same thing... the clicking noise (sounds like its coming pretty close to the windshield under the hood), which seems to go away after the car has warmed up. Did they have DI in 2007, or do I probably have a different issue?
Thanks!

concorso
07-12-12, 08:59 PM
I know this is an old thread, but i didnt want to start a new one with the same question. Mine is a 2007 3.6L and is doing the same thing... the clicking noise (sounds like its coming pretty close to the windshield under the hood), which seems to go away after the car has warmed up. Did they have DI in 2007, or do I probably have a different issue?
Thanks!You should ask in the CTS section. The ticking is coming from Purge Valve Solenoid, and the faster it ticks, the more likely theres a problem. Youll hear it just behind the engine on the battery side.

dboydr
02-05-13, 04:30 PM
The DI 3.6L 300HP engine was introduced in 2007.

RippyPartsDept
02-05-13, 05:21 PM
The DI 3.6L 300HP engine was introduced in 2007.

in Cadillacs it was first used in the 2nd Gen CTS (2008 Year Model... Fall 2007)

93DevilleUSMC
08-04-13, 08:24 PM
My 2006 had this problem. It turned out to be the EVAP canister/solenoid on the top right of the engine. Part was $35, and I got it installed right there in the Autozone lot. Problem solved.