: WANTED: 83 Deville 4100 ECM



MrCadillac (Magnum)
08-11-10, 05:53 AM
I'm looking for a 1983 Deville 4100 ECM.

I just bought back my first car from I was 16. Strange how I had just said I regretted getting rid of it, and then I found it FS on Craigslist. Anyways. I bought it and it refuses to start. It cranks, and will just about fire if you hold the pedal to the floor. I forget what codes it is throwing ,but they were Baro sensor problem, and ECM not getting power. Something like that, I will have to check again.

I will be checking the timing on it. loosen it up, turn the distributor to see if it will fire up. I know some how it was a few teeth off, so the wire placement was off. Not sure if that effected it.

I don't know what years used the same ECM. I know that the RWD Fleetwood was still using the 4100 until around 87. SO far I have not come across one in the LKQ's.

MudAnt
08-11-10, 01:01 PM
I know that the RWD Fleetwood was still using the 4100 until around 87.

85 actually

MrCadillac (Magnum)
08-11-10, 04:52 PM
Good to know they used it for less years than I thought. But I can't say the Olds 307 was that much of an improvement.

Bro-Ham
08-13-10, 02:00 AM
HT 4100 was in RWD deVille from 1982 through 1984 and RWD Fleetwood Brougham from 1982 through 1985. Good luck. :)

Robin Banx
08-14-10, 07:58 PM
Up until a year or so ago, you could still get reman ECM's from your friendly AC Delco dealer. I got one for my 83 FWB. Give them a try. Another jobber which might help would be NAPA.

Cheers......R.