: What happened to my Aux audio / video input?



carter's_sts
08-09-10, 11:26 PM
2006 STS w/Nav...........I haven't tried this in a while, but today I was trying to play an MP3 player through the aux inputs in the center console. No go because I don't see the button anymore to select that for an input.

I did this a long time ago, but I suspect it was before the firmware upgrade on the Nav. It used to be, you hit the hard Aux key and then there was a soft key for audio/video. That's gone.

Did they move it or is it just gone or am I crazy (don't answer that part)?

Thanks.

stevenriz
08-10-10, 11:54 AM
What happens when you hit the AUX button? You're correct, once you hit the AUX button you receive an option on the screen to activate it. As long as everything is working correctly.

EChas3
08-10-10, 09:26 PM
Have you tried it when stationary?

carter's_sts
08-11-10, 01:05 AM
Yes I have tried it stationary and there is no audio/video button. There are only Bluetooth things and the OnStar button.

When I first hit the Aux key it gives a warning about no phone attached with Bluetooth (if it's not), then shows the screen with the soft keys.

This seems weird. I've tried it with the MP3 player plugged in with an RCA cable and not plugged in.

CadillacSTS42005
08-11-10, 08:32 AM
Happened to me once, switching between drivers and then back fixed it.

stevenriz
08-11-10, 10:37 AM
I've also lost my XM button and removing the battery reset everything.

carter's_sts
08-11-10, 11:11 AM
Thanks Guys, I will give those a try. You mean the car battery, not the FOB battery, right?

EChas3
08-11-10, 08:12 PM
When you have the battery disconnected (both cables) touch them together for the full effect.

sapien
08-12-10, 12:48 AM
for being a supposedly high-end stereo/nav unit this thing has some strange bugs. I am scratching my head over an issue where sometimes the presence of my wife's fob causes all my radio presets to get overwritten and also my passenger-side mirror position goes out of whack.

carter's_sts
08-12-10, 01:22 PM
Well I tried the switching drivers back and forth test and that didn't work. Today I'm going to disconnect the battery and touch the cables together.

Does anyone know (I can't remember this), do you have to have something hooked up to the RCA jacks in order for the button to appear? I have tried it both ways, but just wondering. On my wife's Mazda you do have to have something hooked up or it won't switch to aux input.

carter's_sts
08-12-10, 03:54 PM
Well the battery disconnect / touching the cables together did not work. This is what I'm wondering now: If you do have to have a device connected (and sensed) in order to see the button, I'm wondering if the dealer left something disconnected when they replaced my gear shifter Assembly.

I've taken off some of the molding and looked in there and I don't see anything unplugged, but I'm stuck a the point of taking out the black colored inside to the center console that has the RCA jacks. That seems to be held down with some rivet type things that I can't get out.

If someone could let me know if you have to have a device connected to the RCA jacks before you see the audio/video button, that would be great. The funny thing is that the manuals that came with the car don't show the button when they show the Aux screen, but I know I used it before even if I don't remember exactly what it looked like. Seems like it was pretty obvious at the time.

I may let it go and give up on this because I'm under extended warranty now with a 50 dollar deductible and (obviously) I didn't use the feature much anyway.

dkozloski
08-12-10, 04:40 PM
When I push the AUX button after starting the car, first I get a message about no bluetooth phone found. That transitions to four buttons in the upper left hand corner of the screen. The top says "video" below that is the BlueTooth symbol, below that is another "video" button and below that is an "OnStar" button. There is also a lot of stuff all over the screen that is severely grayed out and unreadable.

sapien
08-12-10, 09:44 PM
similar here, can press AUX then VIDEO and it switches to the aux-input mode, even with nothing connected. if you're not getting the VIDEO button then something is wrong...
I think there's a way to reset the unit thru the hidden diagnostic screen

carter's_sts
08-12-10, 11:34 PM
Good idea.......I will try the diag mode to see if there is anything. Thanks for the info guys. When I press Aux, the Bluetooth button is the top button and the video button is nowhere to be found.

Unrelated (I think), I found out today that my traction control disable button doesn't work anymore. It lights up (back light when the headlights are on) but pressing it does nothing, even though the TC light on the dash lights up at start up (so I know the light on the dash is not out). That almost certainly was caused by the dealer working on the shifter back in April.

Not sure I really care too much about that, but I may someday if I get stuck and need to rock the car. It's a good lesson to test absolutely everything when you get your car back from the dealer - hard to remember everything though.

carter's_sts
08-13-10, 11:06 PM
No success with anything in the diag mode. I suspect the tech at the dealer messed something up or more than one thing up in April and I just didn't notice until now. I bet the Nav / audio has a way to sense when the RCA jacks are connected.

One way to confirm this would be for someone who has added the NAV after the fact and does not have the RCA jacks in the center console to see if they have the video button.

But I might be off base because maybe the non-Nav systems have the RCA jacks too.

next2pool
08-13-10, 11:40 PM
I suspect the RCA input module is disconnected. I added a Nav after the fact and didn't care about the RCA inputs and related module. I don't see any indication nor blanked out inputs on the Aux screen.

carter's_sts
08-14-10, 08:43 PM
That sounds like it then..........thanks for the info!