: sts overheating problem



graco369
08-09-10, 10:23 PM
Ok everyone im a pretty good mechanic and this car has me all confused....so two days ago I drove the car about 200 miles round trip and all of a sudden it just went all the way hot. pulled over and let it cool down started it and it was normal then went hot again. so I got home and I put almost an entire gallon of coolant in and added some oil. So everything was good drove it to work no problems then on my way home it did the same thing...except this time I turned the heat on and added coolant and it kinda went up and down and up and down then went normal and i drove it all the way home after that. and on my way home it said low coolant when I just added some previous to that. no dripping in the drive way just had an oil change and that checked fine...and now its saying the oil is at 0% and I can't reset it...any ideas on this would be greatly appreciated.
oh and I warmed it up and checked to see if there were air bubbles in the res. tank and there were non....so im stumped on this car.

EChas3
08-09-10, 10:42 PM
After an overheating episode, the OLM will go to 0% life remaining. If you added anywhere close to a gallon of coolant when COLD, you got problems. I've only read one post of a 2005+ with such issues.

I now see you're writing about a 1999 STS. I think you're looking at a head gasket problem. Check out the older STS forum and/or the Northstar Sub-forum. There're lot's of helpful members there.

Good luck!

graco369
08-10-10, 08:01 AM
do you have a link to any of those??

KRSTS
08-10-10, 11:25 AM
Wrong forum. Sounds like a blown head gasket too me. Same exact symptons my 94 had. Then had coolant in the oil. Engine finally went TU, warped heads and all.

EChas3
08-10-10, 09:33 PM
Seville - Eldo Forum (http://www.cadillacforums.com/forums/cadillac-seville-cadillac-eldorado-forum/)

Northstar Sub-forum (http://www.cadillacforums.com/forums/northstar-performance-technical-discussion/)