: Anyone else find the NavTraffic and NavWeather slow to react in their Onstar units?



algiorda
08-04-10, 07:26 AM
I'm evaluating whether to subscribe to the OnStar NavTraffic and NavWeather package for my SRX. The traffic works pretty well in my area and I'm on highways for my daily commute.

The problem I'm having is the Weather takes 10-15 minutes to appear on my NAV screen after I hit the Info button. Sometimes I get the local weather sometimes I don't and if I get the local weather sometimes I'll get the 7 day forecast other times I won't. If it's this sporadic, I'm contemplating complaining to OnStar and then forgetting about subscribing.

Anyone else have this anomaly?

stevec5375
08-04-10, 07:58 AM
I'm evaluating whether to subscribe to the OnStar NavTraffic and NavWeather package for my SRX. The traffic works pretty well in my area and I'm on highways for my daily commute.

The problem I'm having is the Weather takes 10-15 minutes to appear on my NAV screen after I hit the Info button. Sometimes I get the local weather sometimes I don't and if I get the local weather sometimes I'll get the 7 day forecast other times I won't. If it's this sporadic, I'm contemplating complaining to OnStar and then forgetting about subscribing.

Anyone else have this anomaly?

Yes, I had the problem where you press the Info button and it takes a while to download the weather info. Got a new Radio/Nav installed yesterday and when I pressed the Info button, it was there. Haven't had a chance to see if this new unit fixes that issue or if it's something else entirely.

TexasStation
08-04-10, 12:37 PM
Just to clarify...the NavTraffic is available through XM, not OnStar. Also, the SRX head unit will not support XM NavWeather, which is a more full-featured weather app. The weather features on the SRX are actually provided as part of the NavTraffic subscription. That said, I agree that it is sometimes painfully slow to download the weather data.

donmillard
10-18-10, 11:23 AM
Having the same problem with NavWeather in my 2010 CTS; sporadic service with incomplete or no data. XM has resent signal to radio twice to no avail. Traffic seems to work OK although I haven't traveled outside my immediate area yet.

www03801
12-01-10, 11:51 AM
I bought a 2011 Chevrolet Equinox last week. I am having the same issue where NavWeather is not showing when pushing the Info button. Continues to display downloading info may take a few minutes. I left the screen on for over an hour on a clear day and nothing! The first day I bought the vehicle it displayed. NavTraffic is working fine. My dealership is referring me to XM and XM has sent an activation signal. No such luck. XM is now referring me back to Chevrolet. I am in a loop!

This feature should work on a $35k SUV!

algiorda
12-01-10, 12:04 PM
I wouldn't be so sure NavTraffic is working fine. During my 3 month trial, I noticed NavTraffic displayed the last known traffic event on my screen even if it was hours old. I would get to the traffic location and there was not sign of any traffic event at all; not even residual congestion. I presume is suffers the same lag as the NavWeather.

I let both expire and will not pay extra for such cruddy service. I get more up to date reports from my Droid phone!!!

gary2381
12-01-10, 12:16 PM
I have a 2010 SRX - Premium. I have always wondered what the Info button was for. I have pushed it and waited for more than 15 minutes but nothing ever shows up, just a blank screen. I do not have an Onstar subscription but I do have XM. The XM is the 90 day free trial. Can anyone advise me how to verify that this works?

stevec5375
12-01-10, 05:16 PM
I have a 2010 SRX - Premium. I have always wondered what the Info button was for. I have pushed it and waited for more than 15 minutes but nothing ever shows up, just a blank screen. I do not have an Onstar subscription but I do have XM. The XM is the 90 day free trial. Can anyone advise me how to verify that this works?

You may have to push the Info button again after waiting a while. It may not be designed to "auto refresh".

jcarlilesiu
12-02-10, 12:54 PM
I would call XM. Sounds to me like your trial account doesn't have the navweather and navtraffic activated which is required for those systems to work.

It is free in the trial period. Give it a shot.

chiefmjk
12-02-10, 06:16 PM
I have a 2011 Turbo and on my model I have Nav Traffic but no Nav Weather and no info button. Maybe this is how they now address the weather problem. My 2008 CTS weather was also very slow to come on.

gary2381
12-27-10, 03:33 PM
I would call XM. Sounds to me like your trial account doesn't have the navweather and navtraffic activated which is required for those systems to work.

It is free in the trial period. Give it a shot.


Well I called XM and they told me that my vehicle does not support Nav weather. I tried again pressing Info, waiting 15 minutes, and then pressing it again and still nothing. I did notice that it will change the airport displayed in other areas but all I see is no weather data displayed.