: Cell Phone Not Automatically Connecting Upon Re-entry



kschwed
07-14-10, 12:51 PM
I have a 2006 STS w/ nav and bluetooth. My phone is a Sprint HTC hero. When i get in my car and turn bluetooth functionality on within my phone, it will connect to the car within seconds. When I leave my car and return later, still having bluetooth enabled in the phone, it will not automatically reconnect. I have to disable then enable bluetooth on the phone. My Blackberry curve did the exact same thing. Any ideas why?

MGD
07-14-10, 02:26 PM
I always have to go to the Bluetooth on my phone and say "Connect", if I want to make/receive calls through the car. I figured that was normal, as I may not always want to use the car....

ddavis75007
07-14-10, 02:30 PM
This is not normal. On the phone make sure that the car is authorized. In the car, make sure the phone is marked as default.

kschwed
07-14-10, 04:20 PM
This is not normal. On the phone make sure that the car is authorized. In the car, make sure the phone is marked as default.

I dont have an option to specify that the car is authorized or trusted on the Hero. I think bluetooth was an afterthought on this phone as it doesnt even support bluetooth syncing with the computer for contacts, etc.

The phone is default in the car.

SlickCityStan
07-14-10, 06:59 PM
I have an HTC Eris(AndroidOS) When Ifirst got the phone and paired it with my 05STS it would reconnect automatically whenever I re-entered the car. But since I have had an software upgrade to the phone I have the same problem. I have to manually reconnect each time I get in the car. Have you had any changes to your phone? I will post any solution I come up with as soon as I can if I can.:hmm:

kschwed
07-14-10, 07:36 PM
Funny you should mention updates. I updated mine to Sprint's 2.1 OS today in an attempt to fix this. I've paired it with my car and it worked normally. I havent returned to my car to see if it works automatically yet. I'll let you know.

SlickCityStan
07-18-10, 08:18 PM
I finally got my HTC Eris to reconnect automatically when re-entering my car. The problem was not having the phone set as the default device. Press the config hard key and then press the bluetooth button on the nav screen. The next screen should list the devices paired to your car. select the device you want to connect automatically and press the default key in the lower righthand corner, this will underline the phone selected and your done!

Force-1
07-18-10, 08:38 PM
I finally got my HTC Eris to reconnect automatically when re-entering my car. The problem was not having the phone set as the default device. Press the config hard key and then press the bluetooth button on the nav screen. The next screen should list the devices paired to your car. select the device you want to connect automatically and press the default key in the lower righthand corner, this will underline the phone selected and your done!

That's probably his issue. I have the Sprint HTC Hero too (OS 1.5), and it connects each and every time, no issues.

EChas3
07-18-10, 09:20 PM
The default phone setting does appear to follow the Drivers Fob but I haven't taken the time to prove it. For example, when I drive my wife's car using FOB 2, my cell should be the default. When she drives, hers should be the default.

Has anyone experimented with Bluetooth connectivity to this degree?

ewill3rd
07-19-10, 07:00 AM
If your phone is set as default then take a close look at the car settings in the phone.
You should have some options for the device somewhere.
Most phones do.
As stated, make sure it is a trusted device and see if you can set it to automatically authorize connections.

Blackberry are awful about this.

kschwed
07-19-10, 12:45 PM
Thank you everyone for your advice. Unfortunately, nothing seems to work.

I have my device set as the default in the car.
I've also just upgraded to the new 2.1 android OS. That didnt fix it either.

There is no option for trusted connection or anything of the sort in my phone.

In the car, If i go to config > bluetooth, and click connect to connect it to my phone, it will. So my phone does trust the car and it can connect.

I'm stumped.

next2pool
07-19-10, 01:23 PM
Thank you everyone for your advice. Unfortunately, nothing seems to work.

I have my device set as the default in the car.
I've also just upgraded to the new 2.1 android OS. That didnt fix it either.

There is no option for trusted connection or anything of the sort in my phone.

In the car, If i go to config > bluetooth, and click connect to connect it to my phone, it will. So my phone does trust the car and it can connect.

I'm stumped.

I can't speak for the HTC, but my Pantech has a setting under Connections--Bluretooth,--connect automatically. That setting had to be checked for it to be automatic.

Force-1
07-19-10, 07:31 PM
Thank you everyone for your advice. Unfortunately, nothing seems to work.

I have my device set as the default in the car.
I've also just upgraded to the new 2.1 android OS. That didnt fix it either.

There is no option for trusted connection or anything of the sort in my phone.

In the car, If i go to config > bluetooth, and click connect to connect it to my phone, it will. So my phone does trust the car and it can connect.

I'm stumped.

I am not going to upgrade to OS 2.1, as I've read too many horror stories on the Android Forum. Many are saying 2.1 really screwed up the BT capability. My 1.5 is working just fine, so I'll wait until Sprint corrects the 2.1 issues.

SlickCityStan
07-19-10, 10:37 PM
Just upgraded my Eris to 2.1 and as I posted earlier my blue tooth is working fine.

kschwed
07-20-10, 11:25 AM
I guess it wasnt set to default before, because it works now.