: Some good info on clutch pedal issues.



PISNUOFF
07-09-10, 02:59 PM
Found this, again, while searching the net for something.

http://www.rangeracceleration.com/Clutch_Care.html

liqidvenom
07-09-10, 04:33 PM
thats always been a good site

Stepside
07-10-10, 10:51 AM
Thanks much Brian. An informative read. Thanks for sharing. I will prioritize this . . "ROUND-TUIT"

So, did you read this Randy? . . "You Sir", "have now" . . another 'round-tuit' :)

WesH8398
07-11-10, 11:47 AM
That was a good read. Makes me realize that some of my shifting "issues" (although minimal) might be caused by more than just the crappy stock shifter. I sometimes find myself being locked into and/or out of gears, as if the clutch is not disengaging fully/properly. Now that I've read this, I'm definitely going to have a look at my fluid. I have a feeling that soon after inspecting the fluid, I'll be on my way to 600 clutch pedal presses!! :thepan:

mitchntx
07-11-10, 04:33 PM
I just followed the protocol in the write-up/video. I had a bottle of Castrol SRF on the shelf and used it.

I took a 2 repeats of the procedure to get clean fluid to remain. And it didn't take very much fluid at all ...

Stepside
07-11-10, 10:16 PM
Yup, it took two times and it looked good, but I did 3 times to make sure.
I used Valvoline Pro/Syn 3-4. This will become as regular as changing the oil & filter.

kirchbed
07-12-10, 08:51 AM
Great post. Now on the (growing) regular maintenance list.

Luvacatfight
07-15-10, 09:18 PM
Thank you, Thank you, Thank you.

That is a clutch/transmission repair saver. And makes me feel more confidant about "enjoying the clutch" as long as it's with clean fluid.

Did I mention "Thank You?"

JNR
07-15-10, 09:39 PM
I guess I'm a bit confused on how "clutch dust" gets into a sealed hydraulic system?

PISNUOFF
07-16-10, 12:46 AM
The dust is so fine that it comes in through the seal inside the slave cylinder.

WesH8398
07-16-10, 03:08 PM
I had a look at my reservoir and it was filthy looking ... black almost. I sucked that crap out with a syringe and replaced it with new stuff, then gave the clutch 30 or 40 top-to-bottom pumps, but the fluid in the reservoir didn't seem to "mix" with the old dirty stuff ... it was still clean. What's up with that?

mitchntx
07-16-10, 04:40 PM
Drive it for a couple days and check again.