: big rev matching issue!!!



lilgCTS-V
07-01-10, 01:19 PM
so i pretty much drive the car hard every time i drive it i wouldn't say beat on it but i do play around when i can, so rev matching has never been an issue for me until now, i believe i have a mechanical issue with something, when i blip the throttle nothing happens the RPM's dont move even if i blip it to full throttle it still doesn't move only if i hold the throttle down will it start to rev hard and before this week bliping the throttle would rev up the motor no problem, anybody have any ideas my tuner said my tach module could be on its way out.

CadzillaTN
07-01-10, 03:33 PM
is it just the guage? car still scoots? could be junk motor mount(s)? mine are shot, esp passenger side.. car just bogs and says f you when i floor it...tach barely moves. then as rpms build and squish the mount, she goes but even then it is buick-like... i bet a geo storm could beat me in a roll right now lolz

whisler151
07-01-10, 05:33 PM
so i pretty much drive the car hard every time i drive it i wouldn't say beat on it but i do play around when i can, so rev matching has never been an issue for me until now, i believe i have a mechanical issue with something, when i blip the throttle nothing happens the RPM's dont move even if i blip it to full throttle it still doesn't move only if i hold the throttle down will it start to rev hard and before this week bliping the throttle would rev up the motor no problem, anybody have any ideas my tuner said my tach module could be on its way out.

If you have a code reader plug it in. I had (have) the same issues. It is the Clutch Pedal Position Sensor. I dont have a CEL now but the code is still there. I ordered it from Luke at Lindsay for like $40.

It is the most annoying issue ever. I'd be taking a corner fast and blip the trottle to rev match and nothing. It was like I was kicking a dead cow.

I hope to install the new sensor this weekend.

http://www.cadillacforums.com/forums/2004-2007-cadillac-cts-v-general/134830-clutch-pedal-switch-code-p0833.html

lilgCTS-V
07-02-10, 01:40 AM
that makes so much sense because be i have a check engine light and my clutch petal feels pretty bad lately and i gotta buy a new code reader cuz my dad stole mine and then left it in the jeep in portugal so that leaves me shit outta luck.

whisler151
07-02-10, 08:17 AM
that makes so much sense because be i have a check engine light and my clutch petal feels pretty bad lately and i gotta buy a new code reader cuz my dad stole mine and then left it in the jeep in portugal so that leaves me shit outta luck.

It's ok to drive it. I've been driving mine for months like this. Your cruise control probably doesnt work either.

I'll let you know if the new sensor fixes the issue. I have it sitting in my car, just need to find the time to swap it out. Call Luke for the part, he was way better than my local dealer...even with shipping.

shadybx7
07-02-10, 11:49 AM
and then left it in the jeep in portugal so that leaves me outta luck.

2 Portuguese board members.. that's gotta be a record... my family has a house up north near aveiro

good luck with that sensor guys and thanks for the info

lilgCTS-V
07-02-10, 01:03 PM
2 Portuguese board members.. that's gotta be a record... my family has a house up north near aveiro

good luck with that sensor guys and thanks for the info

yea my house in portugal is near Chaves, and yea my cruise control doesnt work it actually hasn't been working for a while it only works once in a blue moon.

whisler151
07-02-10, 01:34 PM
I just swapped out the sensor. It was more difficult than I was lead to believe. Nothing really tough but there isn't much room in there to get at everything. Knowing what I know now it should only take about 15 minutes.

whisler151
07-02-10, 02:49 PM
Just took her out for a drive and the cruise control works again. Also checked for codes and there were none. Throttle response is back!

lilgCTS-V
07-02-10, 03:08 PM
sick !!! glad to know it was a 40 dollar part lol im gunna take it to the dealer and try to get it under warranty, i hope they honor it even tho i have a tune with some headers, but im just gunna play stupid like i have no idea whats goin on under there

whisler151
07-02-10, 04:09 PM
sick !!! glad to know it was a 40 dollar part lol im gunna take it to the dealer and try to get it under warranty, i hope they honor it even tho i have a tune with some headers, but im just gunna play stupid like i have no idea whats goin on under there

I tried that but the SA played the "aftermarket" clutch card and said sometimes performance clutches will cause that issue.

Oh well, cost me $40 and some time.

SS from the "Wood"
07-02-10, 06:15 PM
what exactly is rev matching?

PISNUOFF
07-02-10, 06:45 PM
Hitting the throttle during down shifts while the clutch is pressed in. It raises the engine rpm to where it would be at the lower gear per the road speed of the vehicle. Much smoother down shifts, the vehicle doesn't have a harsh slow down and actually better for the clutch.

SS from the "Wood"
07-02-10, 07:15 PM
so, if im having harsh vibrations when downshifting now on my monster II (quite a bit more grabby than stock) clutch, not doing this is the culprit?

Twitch
07-02-10, 08:18 PM
sick !!! glad to know it was a 40 dollar part lol im gunna take it to the dealer and try to get it under warranty, i hope they honor it even tho i have a tune with some headers, but im just gunna play stupid like i have no idea whats goin on under there
Showing my service writer I know what I'm talking about worked for me. It went from "yeah yeah, whatever" to "I'll just order both MMs and you can bring it in when they're here".


Hitting the throttle during down shifts while the clutch is pressed in. It raises the engine rpm to where it would be at the lower gear per the road speed of the vehicle. Much smoother down shifts, the vehicle doesn't have a harsh slow down and actually better for the clutch.
Not to mention the diff.