: WTF!? Keyturn, pop and everything is dead.



UnsafeAtAnySpd
06-30-10, 12:02 AM
So I just swapped pads, put the car back on the ground, and got it. I go to turn on the car and something pops and everything dies. No lights or anything. I'm really not sure where to look. Fuses I checked looked good. Thoughts?

I swear, it's one thing after another in my life lately...

ccclarke
06-30-10, 12:14 AM
How 'bout starting with the source of all electrons and work outward?
CCC

MauiV
06-30-10, 12:51 AM
Did you check the fuses under the back seat?

c4ss
06-30-10, 01:44 AM
:yeah:

UnsafeAtAnySpd
06-30-10, 02:01 AM
Okay, maybe I got a little ahead of myself. I don't know what happened but I was checking wires, pulling fuses and putting them back in. I went to the trunk to grab something and thought "Oh yeah, this isn't going to work" but tried to press the FOB anyway and it popped open. Everything seems to be working fine now. Maybe it wasn't grounded well or I dunno? Hopefully it doesn't happen again. Like I said, way too much going on lately... Thanks for the replies.

darkman
06-30-10, 05:11 PM
It seems to me that for anyone with headers in a V, any odd electrical system event, even if it goes away on its own, calls for rechecking all the wires within range of the headers.

UnsafeAtAnySpd
06-30-10, 10:48 PM
Yeah I definitely look down there as I'm one of those who've put a hole in a header. That would suck to go through again.

ewill3rd
07-01-10, 07:59 AM
Sounds like a loose or corroded connection at the battery.
Be sure those puppies are clean and tight.

jnrandall
07-03-10, 11:44 PM
That exact thing happened to me about a month ago. It turned out that the battery shorted somehow. Replaced it and the car is fine.