: 76 eldorado fuel injection



dpoulin17
06-20-10, 09:56 PM
I have a 76 eldorado fuel injection, it runs rough on cold start, blows black smoke, runs rich, for a couple of minutes then runs great, I changed the injectors,but still have problem,, any ideas,,, thanks Dave

drmenard
06-20-10, 11:41 PM
There is a board member, Bruce Roe, that I believe knows these systems better than anyone.. If you have something wrong with your computer, he's the man to fix it.. But first check your two temp sensors... Unplug them and check the resistance with a ohm meter.. with everything cold they should read about the same, within a few hundred ohms.. If they check open,they are bad.... I have some of these sensors....I believe the coolant sensor is in a hose that comes off the passanger side head at the firewall.. The air temp sensor is in the intake, its on the passanger side , rear of the intake... But you could have a bad map sensor, thats in the computer or could be a leak in the hose going to it..

BRUCE ROE
06-20-10, 11:49 PM
I would start by checking the temp sensors, which fail often. However, that doesn't sound like a temp sensor. It could be a bad ECU, perhaps the MAP sensor (located inside the ECU). Having a backup makes swapping ECUs a good test procedure. No charge for testing an ECU if you send it here.

Make sure the vacuum line from the throttle body to the ECU will hold a vacuum. A leak will make it rich. You could pinch the hose on the fuel return line. If it doesn't get richer (more fuel pressure), the pressure regulator has a problem. See a wiring diagram for your ECU and some other stuff is in several ALBUMS of my PHOTOBUCKET. Bruce Roe

http://s93.photobucket.com/albums/l71/bcroe/

(that is a lower case "L"71, not an upper case "i"71)

click on an Album
click on a picture to enlarge + description

eliyahu
09-25-13, 04:53 PM
so, where can I find the air-temp sensor and water temp sensor to replace failed ones?

Eli

drmenard
09-25-13, 10:48 PM
I have them for sale..

BRUCE ROE
09-27-13, 09:34 PM
where can I find the air-temp sensor and water temp sensor to replace failed ones? Eli

I have seen them on Ebay, and Maximum Torque Specialties sells new ones. Bruce Roe

drmenard
09-28-13, 10:14 AM
I have sent him one to get him going.. MTS has them for $110 each

BRUCE ROE
09-29-13, 12:28 AM
If you only have one good sensor, make sure its the one in the coolant. It has
far more effect than the one in manifold air. Bruce Roe

carnut
10-02-13, 10:38 PM
You can swap the air sensor for the coolant temp sensor, same part number! to see if the cold start changes. By that, I mean better or worse. Bruce knows his stuff!

drmenard
10-02-13, 10:54 PM
Eli emailed me today , he got the sensor I sent him and he will be putting it in soon.. Hope he posts his results...