: electrical problems



shrike77
06-13-10, 10:07 PM
1987 Brougham,
The lights on the dash don't light up anymore. Only the battery light and the seat belt light is very faint. Any known problems causing that?
I just got the car, I checked under the dash where the fuses are. The fuses holder seems to be hanging. Shouldn't it be fixed?
I think somebody worked in that area cause the panel was only holding with a screw.

I also don't hear the rear suspension compressor pumping although when the lights were working yesterday the light would come on from time to time. Should there be a whirring sound for the compressor?

shrike77
06-13-10, 10:14 PM
It is the trouble lights that don't work. I think even the fuel gauge shows empty.
And the radio works but its display won't. And the dimmer for the dash lights does not seem to work either

sven914
06-14-10, 01:02 AM
There are three fuses that feed the Telltale (the instrument panel). They are the 20 amp GA-TRANS, LTR, and the A/C fuses. The GA-Trans fuse also powers the fuel gauge and the LTR goes to the radio. I would replace all three and try to get the fuse block back were it's supposed to go.

You should hear the Level Ride Compressor turn on shortly after the engine is turned on, or even after the key is turned to on witht he engine off. The Electronic Level Control is controlled by the Body fuse but if that were blown, you would have no illuminated entry or door locks. Check the electrical connections going to the compressor (driver's side wheel well; next to the master cylinder) and see if the unit is plugged in.

shrike77
06-14-10, 07:46 AM
Thank you very much.
I will start with those things, just have to find the time this week or next week end. I want to fix the electrical problems and after that find out why the compressor doesn't work. Hopefully it is not shot!

shrike77
06-14-10, 10:05 PM
There are three fuses that feed the Telltale (the instrument panel). They are the 20 amp GA-TRANS, LTR, and the A/C fuses. The GA-Trans fuse also powers the fuel gauge and the LTR goes to the radio. I would replace all three and try to get the fuse block back were it's supposed to go.

You should hear the Level Ride Compressor turn on shortly after the engine is turned on, or even after the key is turned to on witht he engine off. The Electronic Level Control is controlled by the Body fuse but if that were blown, you would have no illuminated entry or door locks. Check the electrical connections going to the compressor (driver's side wheel well; next to the master cylinder) and see if the unit is plugged in.



Like they say, YOU THE MAN!
It was only a fuse, although there is one light which does not light, it probably shouldn't, it is the STOP ENGINE light.

Compressor is good but either there is a leak either the shocks are shot, I suspect the shocks are shot

I have a fuse missing, EXH. Should I have it? What is it for exactly?

shrike77
06-14-10, 10:06 PM
Oh and my mistake, it is not the fusebox hanging but a block with some relays and three fuses

csbuckn
06-15-10, 12:02 AM
Like they say, YOU THE MAN!

As time goes on, you will find he is priceless. Wait til he starts talking about transmission...

sven914
06-15-10, 12:39 AM
Like they say, YOU THE MAN!
It was only a fuse, although there is one light which does not light, it probably shouldn't, it is the STOP ENGINE light.

Compressor is good but either there is a leak either the shocks are shot, I suspect the shocks are shot

I have a fuse missing, EXH. Should I have it? What is it for exactly?

I don't remember an EXH fuse, and my book doesn't say anything about it. The fuse blocks in these cars were made to be used on other GM cars, so you'd probably find an EXH fuse on a Chevrolet feeding the Clutch Switch or something.

The check engine light should come on at bulb check and stay on for a few seconds after the engine turns on. It's probably the bulb, but it could be the lamp-driver module (it's fused off the GA-TRANS fuse and controlled by the the computer, so there'd be more symptoms otherwise).

shrike77
06-15-10, 08:03 AM
Sorry, I was not clear. The stop engin oil lamp comes on.
There is another STOP engine lamp and it says saomething about coolant temperature. But it looks to be only a "phantom light"

The only thing that does not work right now is the display on the radio but that must be internal

sven914
06-15-10, 10:05 AM
^Never mind I read it wrong...

The one that says "Stop Engine Temp" and is on the right side of the Telltale; it doesn't do anything.

shrike77
06-15-10, 12:08 PM
Thanks for all that info!