: TPMS and Radio Issue



junoreactor
05-31-10, 03:44 PM
I've been having my left front TPMS sensor read --- for a little while now. It's not constant though. When I had my stock wheels on it would happen occasionally. Then I bought the Veneto's from Wheeldude with new TPMS sensors. After installing them, I performed the TPMS reset to sync the 4 new sensors to the car and the horn honked the appropriate number of times. So i'm having the same intermittant --- problem on the same wheel position on two different sets of TPMS sensors. Also I'm having terrible to nonexistant FM radio reception (often can't pick up a channel that is broadcasting in the same town). I read in the faq that the first step to relearn the TPMS was to lock and unlock 3 times to sync with factory antenna system.

Does anyone have an idea what could be going wrong here, that I'm having the TPMS --- reading and very bad FM radio reception? Are these two things connected in some way? I've been searching for forums and looked at the FAQ and don't have a conclusion. I'm at a loss here on what else to check.

darkman
05-31-10, 07:04 PM
There appear to be two common components between the TPMS and the radio reception. Both systems use the Attenna Control Module (see attached) and the AM/FM attenna grid in the driver's side rear glass.

junoreactor
05-31-10, 07:12 PM
Thanks for the tip darkman. You sure do come up with great info real fast :) That part looks like the kind that would be on backorder forever. Let's hope not. Any idea how much it'd cost from a dealer? I'll have to call Luke tomorrow and check it out.

darkman
05-31-10, 07:37 PM
Thanks for the tip darkman. You sure do come up with great info real fast :) That part looks like the kind that would be on backorder forever. Let's hope not. Any idea how much it'd cost from a dealer? I'll have to call Luke tomorrow and check it out.

I cannot say. GMPartsDirect's data base, which I only use for reference shows two possible parts (modules) - one with an MSRP of $225 and another with an MSRP of $300. Both have discount prices of about half that before shipping BUT neither is actually available if try to check out (I was trying to determine shipping charges which can be significant from GMPartsDirect).

The problem can also involve loose wiring or grounds, which can be tested with a scantool. You may want to have someone diagnose it if throwing parts at it becomes expensive.

junoreactor
07-19-10, 03:48 PM
I finally got the car to the dealer to get something fixed and I had them check the sensor issue. They suggested replacing the antenna module which you posted the instructions for. I must say that's hell on your hand and wrist to put it in without dropping the headliner! After I put the module in I lost all control of my key fobs so back to the dealer I went to get them programmed to the new antenna module.

I think I get marginally better FM reception but it could be a placebo effect. However I still have the dashed lines on the TPMS sensors occasionally. Still the front left wheel is having the most problems. Today on the way to work I lost both the front readings then about 10mins later or so I lost the back left sensor reading.

I'm about ready to give up on this. I'll just say there are gremlins in the electronics.