: EBCM question



dac675
05-24-10, 07:59 AM
The magic of modern electronic control systems...

My electronic brake control module has been acting up intermittently for a few weeks. When it happens I am getting "service stability system" and "service steering system" messages on the screen, and ABS, Brake, and Trac lights on the dash. The brake lights also remain on all the time when it would happen. Scanning the computer showed a "bad EBCM ground" code, although the ground checked out great (less than .15 volt drop with 10+ amp load). I replaced the ebcm with one from same year, same assy code and same ecu code, and the brake lights now work and the steering system service message has gone away. I still get a service stability message on startup and the trac off light stays on all the time. Has anyone replaced the EBCM before? If so, did you have a similar issue? Do I need to have it reprogrammed with the tech-2? Any help would be appreciated.

Baltimore07V
05-24-10, 09:43 AM
The magic of modern electronic control systems...

My electronic brake control module has been acting up intermittently for a few weeks. When it happens I am getting "service stability system" and "service steering system" messages on the screen, and ABS, Brake, and Trac lights on the dash. The brake lights also remain on all the time when it would happen. Scanning the computer showed a "bad EBCM ground" code, although the ground checked out great (less than .15 volt drop with 10+ amp load). I replaced the ebcm with one from same year, same assy code and same ecu code, and the brake lights now work and the steering system service message has gone away. I still get a service stability message on startup and the trac off light stays on all the time. Has anyone replaced the EBCM before? If so, did you have a similar issue? Do I need to have it reprogrammed with the tech-2? Any help would be appreciated.

Check your steering wheel position sensor. It is a known weak link in these cars. I had mine replaced under warranty a few months ago, and it threw a "Service Stability System" message. I don't know if it produces that code, because I never had it scanned, just worked on under warranty. There have been several documented cases of the SWPS having issues.

heavymetals
05-24-10, 05:04 PM
150 millivolt drop is high across a junction.

The grounds in the V are all suspect and with age, the aluminum doesn't get better, it gets worse.

dac675
06-03-10, 03:18 PM
Do any of you Caddy-techs know how much labor is involved in re-programming the EBCM? I am going on the assumption that this is what now needs to be done, and I did not want to get hosed by the service writer when I go in there? Anyone know how much time or what the standard charge for doing this process is?

Thanks!

darkman
06-03-10, 07:26 PM
Do any of you Caddy-techs know how much labor is involved in re-programming the EBCM? I am going on the assumption that this is what now needs to be done, and I did not want to get hosed by the service writer when I go in there? Anyone know how much time or what the standard charge for doing this process is?

Thanks!

The reference I have does not isolate the reprograming procedure, but the time allowance for replacing the EBCM is 1.3 inclusive of reprograming the new unit which is listed as a necessary step in the replacement procedure.