: Nav. Problems! Please Help....



still1graphics
05-23-10, 12:02 AM
I have a 07' escalade w/ the nav. and i have the 2010 nav. disc in it. The problem i have is when im going from point A to B a straight shot down the interstate to another town, the nav. tries to send me on a wild goose chase instead of traveling straight down the highway?? Why is this.... I have tried the shortest, quickest and oter routes and they all seem to try and take me off the best route (straight down the interstate) and send me on back roads? Can someone tell me what to do, or whats going on??? i have a $120 garmin that beats the pants off the cadillac gps.... It always get my wife lost or sends her way out of the way??? Thanks for any help!!:confused:

Big Windy Ext
05-23-10, 10:03 AM
Try going to a POI , whatta cluster . I also have the 2010 version , the only thing I can figure is GM gave the software company the runaround and now they chuckle giving GM's customers the runaround . The software is not as good as Garmin or Tom-Tom .

COBlackZ06
05-23-10, 10:43 AM
That's interesting because it's exactly the opposite of the issue I'm having.

A couple of months ago, I bought a 2007 EXT as a Certified Pre-Owned, and the Nav-Disc that came with it was the 2005 version. There are two principal routes I can take to go from where I live in the Denver area down to Colorado Springs (I-25, or Colorado Highway 83). I generally prefer to take Highway 83 because, as a two lane road, its more lightly travelled. The Navigation system seems to want to route me only on the Interstate, no matter how I try to select the route.

I was thinking about getting the 2010 update disc, but based on what you're telling me here, I'm not so sure now.

North49
05-23-10, 09:55 PM
I just bought an 09 Nav Disk on ebay. The one in my truck was scratched. My salesman is paying for it so I offered to help him out by picking it up in the US. It seems the '09 version works very well and would be the disk of choice.:2thumbs:

vfjdesign
05-26-10, 11:38 PM
Everything I have read states the same as North49, go with the 2009 disc! I finally gave up and put a pioneer in mine, much better maps...guess what though, the Pioneer guys are complaining about them. I guess all units have some issues. Good luck

WaterKing
05-29-10, 04:04 PM
I have a 2008 and 2007 with 2009 discs and they work great actually has the new highway which was missing on old discs.......But I bet your setup is wrong for some reason and "allow major roads" has been disabled. With car running and Nav on go to CONFIG then to Navigation then make sure Allow Major Roads has an orange color for selected. If not or even if so, activate it, then deactivate it then activate it again. That should take care of it.

silverws6ta
05-30-10, 06:27 PM
I have a 2008 and 2007 with 2009 discs and they work great actually has the new highway which was missing on old discs.......But I bet your setup is wrong for some reason and "allow major roads" has been disabled. With car running and Nav on go to CONFIG then to Navigation then make sure Allow Major Roads has an orange color for selected. If not or even if so, activate it, then deactivate it then activate it again. That should take care of it.

This solved mine!! Good find! i've noticed this in my car before; but never turned it off; Evidently when the firmware is updated by the disc it defaults it to off!