: CEL P2723, PO 700 and PO430



cadillac94pimpin
05-10-10, 11:11 AM
Man I had a rough weekend!!!

CEL iluminted around Thursday. Checked the code it was PO430 bank 2 cat I believe has gone bad. Cleared it and it came back a day later. Car was driving fine no problems. Now Sunday got in the car and the trans starts slipping real bad and the car wont move unless i give it gas.
Sort of felt like a high stall converter. Cell went on again now with codes
P2723 and PO700, I looked them up Solenoid number 5 is stuck off. Along with a TCM faliure (PO 700) The car goes into limp mode after the cell turns on. I tried to run some tests with my friends scanner but the only thing I was able to acomplish was to put the car in 5th gear with the scanner so I can drive it to Cadillac. I do not want this car on a tow truck!!!

The solenoid that is stuck has nothing to do with 5th or 6h gear so the scanner says. That's why we put it in 5th and were abel to drive it without any issues. I have to take the Stage 1 intake and D3 Box off before taking it in.

The warranty book says that the Cat's are covered under the emmisions warranty for 8 years or 80,000 mi. Thank GOD!!!

Do you guys think I will be able to get the Trans covered under my expired facotry warranty? It expired JAN 31 2010. This car has been in the shop sevreal times. The entire rack was replaced, the DIFF was replaced and it sounds like it has a slight whine again. Some other things went wrong as well.
Im getting ticked off about this and It reall should be covered!!

I do have the GMPP major gaurd to fall back to but I shouldnt have to use it my car only has 37,000 miles on it.

Has anybody else had this trans problem?

CIWS
05-10-10, 11:43 AM
I know it may sound stupid, but try pulling your neg battery terminal for about 15 min, hook it back up and see if your transmission codes clear.

If you do pull the battery remember you'll need to retrain the auto up feature of the windows.

cadillac94pimpin
05-10-10, 01:01 PM
I know it may sound stupid, but try pulling your neg battery terminal for about 15 min, hook it back up and see if your transmission codes clear.

If you do pull the battery remember you'll need to retrain the auto up feature of the windows.

I forgot to mention I did that already. Yeah it cleared the code but the problem was still there and the code came back quickly.

How do you re program the auto up. They all work except the front passenger.

CIWS
05-10-10, 01:46 PM
How do you re program the auto up. They all work except the front passenger.

Roll the window(s) all the way down, then all the way back up again and hold the switch up for another second once it's up. That should do it.

TimmyC
05-13-10, 12:00 AM
I'd bet it's the TCM causing the code and the tranny problem. Let us know how it pans out.

cadillac94pimpin
05-13-10, 11:35 AM
After 2 fulll days plus this morning they finally called. They hadent even called me at all to give me updates. I guess they didnt have anything to tell me. They said they "ordered a part" and it should be there tommorow. They also said they will "SEE IF THAT FIXES IT"

lamo I guess they really dont know whats wrong. The solenoid is a part of the entire valve body I think. So that whole thing must be replaced. If there was debris causing it to get hung up then thats another probelm. Now what could the debris be. Probably torn up clutch packs. Then it would need a rebuild or a new trans.

There is a TSB out there for solenoid's getting stuck. It is for some type of software run cleaning procedure within the TCM. It just has to be activated with a Tech 2 I guess.

The other TSB I saw was some kind of ring gear was made faulty from the factory for the 2006 models all across the board (not just V's).

They do have an improved part for that. We will see what happens I guess.