: Passenger airbag questions



PJGross
05-03-10, 04:43 PM
Did a quick search but didn't see anything on this.

My '05 is sporting a "Service Airbag" indicator for the passenger airbag. Usually my wife sits there, but I was letting her drive and sometime after my butt was in the seat the service indicator went off. Comes on everytime you start the car. Red warning light in dash stays lit.

Should I have the car scanned to see where in the system the fault is? Is the sensor known to go out in the seat? If so, anyone have a part #?

If anyone has any relevant thread links, please post. Sorry if this has been covered but searching under "airbag sensor" didn't pull up any obvious threads.

Thanks for input,

PJ

PS- anyone know if the default is to not deploy the airbag in this condition with a crash or if it is to deploy it? I would guess it "would" but wife says she won't ride in it if it won't deploy..... hmmm. Might have to think about how I answer this one. :)

JimmyH
05-03-10, 04:56 PM
This is likely irrelevant to your situation, but in two other cars, I was installing some wiring, and when I moved the A-pillar interior trim finishers, I got service airbag lights on both cars. They had to take the car to the dealer, who plugged in and simply reset the light. There was nothing else wrong in my situation.

Again, I don't know if that helps you, but something to think about until others chime in.

odla
05-03-10, 04:57 PM
how much do you weigh?

PJGross
05-03-10, 07:01 PM
ok, I know I need to lose a few pounds, but I'm 225 right now. :) And I don't bust the driver side sensor! Wait, maybe there isn't one for the driver. I usually set my computer bag on the passenger seat. Could I have confused it with setting light loads on it?

I guess I should see about reseting the codes w/ a scanner and maybe it was a one time glitch vs a bad sensor?

-PJ

JimmyH
05-03-10, 07:56 PM
I wont say it's not a bad sensor, but I tend to doubt it, since I have never known anyone who had one fail.

RockinV
06-27-10, 11:06 AM
Did you ever get this problem fixed?
I have had a airbag light on (along with the "pass airbag off" light) for a few months now...
The dealership in Hawaii said they would change the passenger seat for $880.... so I haven't messed with it.
I also always drove with my computer bag sitting on the passenger seat.... hardly ever had a person in it... then one day the airbag light started flashing and by the end of the week it was on steady.

I know, eventually I will have to take it into a dealer here in Colorado Springs, ...I was just wondering if you had any additional information.

SS from the "Wood"
06-27-10, 02:26 PM
+1 on a cure for this issue... I've had the pass seat out to try and pinpoint this, but maybe I didn't look hard enough.

photorobb
05-25-11, 11:40 PM
I have had the same thing just start happening to me in my '05. I found this while in my search, it seems to be similar but doesn't offer a solution.
http://www.cadillacforums.com/forums/cadillac-sts-forum-2005-through-2012/79466-passenger-airbag-sensor.html

RockinV
05-31-11, 01:51 PM
Just an update on this:
A few months back, I took the car into the dealer and told them my passenger presence sensor was bad. They concurred and changed it out for a mere $630 (Two hundred cheaper than the dealer in Hawaii). I got the car back and all worked great.
Then a couple months later I heard that there was a recall coming out for CTSs concerning the airbag system. I called Cadillac and they confirmed that a recall was coming out for the same problem I had, but they were not sure if it was also for the CTSVs?!?!
They took my info and told me they would contact me if my car was included. About a month ago I received a letter and a couple follow up calls concerning the recall, I sent in my receipt and Cadillac fully reimbursed me for all the repairs. It took a while but now I have a fully functional airbag system, and Cadi paid for it.

rand49er
05-20-12, 09:23 PM
Got the "Service Air Bag" on my NAV screen several times yesterday and a few times today along with the little red guy on the dash. Drove about 40 miles this afternoon (with a few stops and restarts), and got nothing. I'm like, WTF?

None of these threads seem to offer a specific, definite cause and solution.

Can anyone offer an up-to-date, rational, correct analysis of this phenomenon?

acaringnihilist
05-21-12, 07:11 AM
Same thing here. It came on about a couple months ago, then it went away. Now its back.

odla
05-21-12, 10:14 AM
this happens in my wife's car. i found that making sure that the sensor under the seat is secure makes the problem go away. its happens when the seat is moved a
lot. i just reach under and make sure its tight and it goes away.

Cadillac Cust Svc
05-21-12, 10:47 AM
While I have no official diagnosis to offer, I would definitely recommend seeing your dealerships for their diagnostic tests. If you'd ever like me to investigate your particular Cadillac for recalls, etc., please don't hesitate to PM or email (Katie_Lucille@gmexpert.com) me with your name and VIN.

rand49er, if your "Service Air Bag" message appears, that indicates there is a problem with your airbag system. Your owners manual suggests having your vehicle "serviced by your GM dealer immediately," if this message occurs. See the "Airbag Readiness Light" portion of your manual on page 3-39 for more detailed info! However, if you're able to eliminate the message using odla's method (above), please let us know!

Best,

Katie
Cadillac Customer Service

rand49er
05-21-12, 02:14 PM
While I have no official diagnosis to offer, I would definitely recommend seeing your dealerships for their diagnostic tests. If you'd ever like me to investigate your particular Cadillac for recalls, etc., please don't hesitate to PM or email (Katie_Lucille@gmexpert.com) me with your name and VIN.

rand49er, if your "Service Air Bag" message appears, that indicates there is a problem with your airbag system. Your owners manual suggests having your vehicle "serviced by your GM dealer immediately," if this message occurs. See the "Airbag Readiness Light" portion of your manual on page 3-39 for more detailed info! However, if you're able to eliminate the message using odla's method (above), please let us know!

Best,

Katie
Cadillac Customer ServiceThanks, Katie. Let me monkey around with it a little first, then it's off to the dealership if that doesn't work.




this happens in my wife's car. i found that making sure that the sensor under the seat is secure makes the problem go away. its happens when the seat is moved a
lot. i just reach under and make sure its tight and it goes away."It's tight?" Do you mean the connector that's plugged into it? Also, is it located right in the middle of the passenger's butt imprint?

Thanks!

odla
05-23-12, 06:42 AM
yup the connector under the seat. Sucks if its tight and still not working.

rand49er
05-23-12, 07:22 AM
Thanks, odla. I'll check this morning.

I am not crazy about spending a chunk of money on getting this issue fixed. :annoyed:

odla
05-24-12, 09:54 AM
yea i hear ya. That's why i tried everything i could first. Good luck.

PJGross
05-25-12, 02:16 PM
Guys,
There is an active recall for the passenger side airbag sensor in "select models" GM cars. I must have posted it in its own thread separate from this one and didn't close out this thread. I told my local dealer about it for months, but it took until spring of '11 for it to show up in their computers as an actual recall.

The wiring harness was installed with a "kink" in the wiring that over time would lead to a worn/broken connection and a fault. I'll find the other thread and post a link to it in the next post.

(I did get a letter in the mail AFTER I had the dealer fix it.)

-PJ

----------

Here's the old thread with all the details:
http://www.cadillacforums.com/forums/2004-2007-cadillac-cts-v-general/218146-new-cts-recall-2.html

My update for this thread is that the recall # is 10355. I think I had a link to the NHTSA notice in that thread. I received a letter, as did some others, but I would call and have them see if this recall is active for your VIN. Not sure what you can do if your car is not in it but you suffer from the same issue. Sounds possible since they said around 100,000 vehicles were effected?

Good luck on this! Hopefully you don't have to shell out $$$ for a silly bad sensor.

-PJ

rand49er
05-25-12, 03:20 PM
Guys,
There is an active recall for the passenger side airbag sensor in "select models" GM cars. I must have posted it in its own thread separate from this one and didn't close out this thread. I told my local dealer about it for months, but it took until spring of '11 for it to show up in their computers as an actual recall.

The wiring harness was installed with a "kink" in the wiring that over time would lead to a worn/broken connection and a fault. I'll find the other thread and post a link to it in the next post.

(I did get a letter in the mail AFTER I had the dealer fix it.)

-PJ

----------

Here's the old thread with all the details:
http://www.cadillacforums.com/forums/2004-2007-cadillac-cts-v-general/218146-new-cts-recall-2.html

My update for this thread is that the recall # is 10355. I think I had a link to the NHTSA notice in that thread. I received a letter, as did some others, but I would call and have them see if this recall is active for your VIN. Not sure what you can do if your car is not in it but you suffer from the same issue. Sounds possible since they said around 100,000 vehicles were effected?

Good luck on this! Hopefully you don't have to shell out $$$ for a silly bad sensor.

-PJThanks, PJ. That NHTSA link didn't work (SERVER ERROR), but I'll run with the rest of the info.

This forum and its members rock. :rockon:

PJGross
05-25-12, 07:46 PM
Randy,
Just so you have it, the original NHTSA announcement was: 10V644000
Here's a link to at least part of it:
http://repairpal.com/cadillac-cts-recall-10v644000

It took months for this recall to finally materialize. In that notice, the NHTSA id's the recall as 100355 but the actual recall # is 10355. (dealer did not help me figure that out, either. I called Cadillac customer service and referenced the NHTSA doc and they had nothing on it for months, either. I had to call NHTSA myself and be told that "of course that's an error, the GM recalls only have 5 digits") Very helpful dealer. :( When performing the recall, that same dealer decided to "flash" my 60lb injector'd, maggied V as a "favor" to address some driveability issues....... after which I got a call that my car wouldn't start. Not that I'm bitter or would ever go back that that particular dealer in Troy, MI ever again.

On a positive note, the wife refused to ride in my V for the 5 months or so the airbag was out. :) Hey, it was either that or let her drive it.... and that wasn't happening b/c I hate that she short shifts even when trying to accelerate. :( "Honey, the supercharger starts building boost at 3000 rpm, that noise doesn't mean to shift!!!!" The agony.

Cadillac Cust Svc
05-30-12, 02:56 PM
If we can check to see if the recall referenced by PJGross applies to your vehicle, please send us the last 8 digits of your VIN so we can look to see if there are any open recalls on your CTS(-V).
Best,
Sarah (Assisting Katie)
Cadillac Customer Service

yonexsp
08-14-12, 11:17 AM
I have the same issue on my 05 V, GM is told me that my VIN is not listed.

But they have covered it under the extra warranty for this issue today