: What is wrong with my headlights!?



Matt05V
04-27-10, 02:46 PM
So I turn on my headlights and the driver side doesnt turn on. I turn the switch off and on several times and it turns on...not more than 3 seconds later, the passenger side turns off with the driver side still on! I turn the switch off and then back on, they both come on. WTF!?

This is a major annoyance, not to mention not the greatest for the HID's. I have DDM tuning 6k bulbs. They've been on the car since september of last year and haven't had a problem yet. Is it something in the wiring? the switch? the bulbs themselves? I have the factory ones but I dont want to tear everything apart if I dont have to.

Thanks in advance.

2manycars
04-27-10, 03:05 PM
My first guess... a dirty switch. Get some TV tuner contact cleaner from radio shack... and spray it in there. May not fix it but it is a cheap fix if it does.

JimmyH
04-27-10, 04:50 PM
stay away from aftermarket capsules. Stick with philips or OSRAM.

MAPerformance
04-27-10, 07:51 PM
I have this problem a lot with aftermarket HID's. I believe its the ballast, because the I have used DDM/Shitty ballast in the past with good bulbs and it still did the same thing.

Andringa
04-28-10, 02:14 PM
It doesn't sound like it could be the switch, because it is only one side.

It sounds like you have original ballast with ddm tuning bulb? or ddm tuning bulb and ballast?

Do you have this problem when the engine is turned off? There is a wire loom in the engine bay that can rub on the front passenger side spark plug boot. My passenger headlight flickers sometimes while accelerating and I think that it is because of arching between the spark plug wire and the electrical loom. I plan on zip tieing and insulating the loom so that it doesn't rub any more.

Finally, if you want to try the original bulb to isolate the problem, I have read on hear that you can get access to the headlights by removing the fuse box that sits behind the headlight, instead of removing the bumper.

Goodluck.