: Turning off rear 02 sensors....help



crankedupforit
04-18-10, 06:09 PM
My tuner has done great job with tuning my V with headers and CAI. I'm really happy with the way the car is running. The problem is he's not an LS guy, but rather a german car specialist and a few Cobras. We can't get the MIL light to go off for the rear 02 sensors. Since the free flow cats were mounted, the ECU thinks there is an efficiency problem. We've turned off the lines that analyse the rear 02 readings and the lines that set the MIL light (4 all together). We thought we really had it this time. A day later that bitch came back yet again. This is about the third time we've been F!in with this thing. I've scanned it and erased it, hoping by some act of God it will not come back. I can't renew my plates pending an emmission test. Any LS tuner guys that can think what we're missing to get these rear 02 sensors off and no MIL light?

SkullV
04-18-10, 06:31 PM
What tuning suite is he using? If it is HPtuners PM me and I'll walk you through it.

crankedupforit
04-18-10, 06:37 PM
What tuning suite is he using? If it is HPtuners PM me and I'll walk you through it.

Thanks Ted, but unfortunately it's EFI live.

SkullV
04-18-10, 06:41 PM
Thanks Ted, but unfortunately it's EFI live.

Either way the codes will be the same.

For an LS6 uncheck SES enable and set all of them to No Error Reported:


P0054
P0060
P0137
P0138
P0140
P0141
P0157
P0158
P0160
P0161
P0420
P0430
P2A01
P2A04


That will keep your CEL off and you will pass OBD2 emissions.

crankedupforit
04-18-10, 08:35 PM
Either way the codes will be the same.

For an LS6 uncheck SES enable and set all of them to No Error Reported:


P0054
P0060
P0137
P0138
P0140
P0141
P0157
P0158
P0160
P0161
P0420
P0430
P2A01
P2A04


That will keep your CEL off and you will pass OBD2 emissions.

Thanks so much Ted!! There are so many sensor 2 codes in the program that it's like searching for a needle in a haystack. I noticed that you don't need to turn them all off like P0156, 159, PO136, 139. They are for sensor 2 also. Is that OK? Or if you turn those off will you flunk?

Mike

SkullV
04-18-10, 08:50 PM
The codes you listed are not in the list of DTCs for an LS6 CTS-V in HPtuners.

crankedupforit
04-18-10, 08:54 PM
The codes you listed are not in the list of DTCs for an LS6 CTS-V in HPtuners.

10 4. They are generic codes and I didn't have the LS6 stuff on hand. Thanks again for your help. I'll sort it out this week and let you know.

bneal1022
04-18-10, 09:07 PM
anyone have experience with eliminators? Will that prevent codes from popping? Where can i research? anyone have a link or brand. If I drive less than 5K a year I am exempt and want the benefits of catless pipes - maybe unless it causes MANY other peripheral problems...thoughts?

PISNUOFF
04-18-10, 09:12 PM
You should turn off all codes associated with HO2S Sensor 2 and also Catalyst System Efficiencies (P0420, P0430, etc.).

Ted: I just tuned an '04 and it had P0136 and P0156. Yes, turn off 0156 and 0136. I don't see 0139 and 0159, but if they say Sensor 2 then turn them to No Error Reported also.

SkullV
04-18-10, 09:30 PM
Here is the list of codes from my 05 in the latest beta from HPtuners....

Those codes do not appear in 05 but I just downloaded a stock tune from 04 and they do appear in 04....very interesting!

Here is the top of the list from my 2005
http://i211.photobucket.com/albums/bb102/rockyrubicon/codes.jpg

Here is the top of the list from the 04 tune:
http://i211.photobucket.com/albums/bb102/rockyrubicon/codes04.jpg