: 98 Sedan Deville-TRANS HOT-IDLE ENGINE



JOHNNY Z
08-23-04, 12:18 AM
and its stuck in what feels like 2nd or 3rd gear. Heres the scenario. I travel about 95 miles on the interstate and slow down from about 75 to 40 to approach the toll booth at the Goethels bridge in New jersey. I feel 2 hard shutters and the seconds later the SES ligt comes on. I pull over to the shoulder and the DIC says TRANS HOT IDLE ENGINE. So I do that for about 15 minutes. No change. I clear the PCM code ( forgot what it was) and of course it comes right back on. I am late for a funeral here so off we go with the Trans hot and SES still on. I hit crazy standstill traffic in Staten Island and jump off the expressway. Limp to my Brother in laws house. I go to park it and I've got NO REVERSE at all. pull into an open sparking spot and thats where it sits now. The car ran like a dream the whole trip and has about 70K miles on it. Do I need solenoids or a trans here??? If it needs a trans a junkyard is the source of where it coming from because I am absolutely finished with the Cadillac "Quality" and this biotch is going.

BeelzeBob
08-24-04, 09:53 AM
and its stuck in what feels like 2nd or 3rd gear. Heres the scenario. I travel about 95 miles on the interstate and slow down from about 75 to 40 to approach the toll booth at the Goethels bridge in New jersey. I feel 2 hard shutters and the seconds later the SES ligt comes on. I pull over to the shoulder and the DIC says TRANS HOT IDLE ENGINE. So I do that for about 15 minutes. No change. I clear the PCM code ( forgot what it was) and of course it comes right back on. I am late for a funeral here so off we go with the Trans hot and SES still on. I hit crazy standstill traffic in Staten Island and jump off the expressway. Limp to my Brother in laws house. I go to park it and I've got NO REVERSE at all. pull into an open sparking spot and thats where it sits now. The car ran like a dream the whole trip and has about 70K miles on it. Do I need solenoids or a trans here??? If it needs a trans a junkyard is the source of where it coming from because I am absolutely finished with the Cadillac "Quality" and this biotch is going.


So what is the situation with the trans when you start it up now that it is cold from sitting...??? If the trans hot message is showing up still then likely the trans temp sensor is failed and needs to be replaced. If the trans temp message is gone now that the unit has cooled then possibly there is an internal problem that is causing the trans to overheat and loose gears. Did you check the fluid level?? If there is a cooler line leak or something and the trans is low on fluid it will eventually overheat and loose gears.

JOHNNY Z
08-24-04, 02:30 PM
I started it cold yesterday and it has no reverse and is still stuck in 2nd or 3rd. Been towed to a tranny friend I have. He opened it today and says it appears the pressure switch failed and the unit ran dry causing lots of damage to lots of parts. He is looking for a used unit now to rebuild as too many parts are too far damaged in the current unit. This should be one of the most expensive repairs EVER. I will probably sell this car very soon after and I would like to go back to a 93 Deville with a 4.9. I never had these kinds of crazy expensive repairs until I hit Northstar years. Bobby you remember my STS throwing a rod a few months back too. This is great.

JOHNNY Z
08-28-04, 09:25 PM
Well i got a new rebuilt trans installed. Drove 85 miles and traffic slowed and so did I. Guess what- Trans hot idle engine comes on again. I wait ten minutes restatrt and off I go another 20 miles in stop and go traffic. No message ever again. car was running a consistent 197-217. Just did dexcool and GM pellets about 3 months ago and car never runs hot. Anyone have any thoughts. I was going to flush the radiator thouroughly and redo the dexcool and pellets again but shouldn't see the need to do it. I mean if the radiator and engine were running hot then I could see it.

peteski
08-30-04, 04:59 AM
I'm not 100% sure but I think when a code get set, it stores a snapshot. You could look at all the stored snapshot parameters and that might help you in determining what was wrong.

If for example the snapshot's coolant temperature looks normal, but the transmission temperature is really high, then you probably have an electrical problem with the transm. temp. sensor. Maybe the sensor itself, wiring or the PCM is intermittantly bad...

Since you had tranny replaced, I assume they already checked all the fluid passages (like the tramsmission cooler lines)?

Peteski

JOHNNY Z
08-30-04, 12:53 PM
I pulled codes immediately and heres what was there. PCM0218(H) Trans hot, PCM0603(H) control module reset, IPC B1255(H) Data area full, IRC U1255(H) Class 2 common malfunction, RFA U1300 Class 2 short to ground, MMM B1983(H) Device pur circuit low. All in history. The first one (Trans hot) was probably caused by the last 5. It appears as though something was not grounded correctly or shorted to ground momementarily. I cleared all codes and have since reflushed the radiator and engine and new dexcool and pellets. I also added a 16000 GVW heavy duty trans cooler on the lower return line yesterday. I have not had the cahnce to take an 80 mile ride but did take a few 25-30 mile rides and I worked the engine and trans a wee bit, not much just a kickdown or two and cruised at 75 or so for a bout 7 miles. No problems at all no codes, engine temp very good at 196-199. The Positive terminal was a little loose on the battery so I am wondering . I don't think the trans or engine could run any better. But what melted the crap out of the old unit??? I mean will this happen again??? I have really low confidence at this point but hate to bail out after a 2000 repair and see someone else go 80000 miles trouble free.

peteski
08-31-04, 06:38 AM
I don' t know much about OBDII codes ( I have a 93 Eldo). But in a snapshot it isn't the trouble codes you are after - it is all the data parameters. By examining the various specific data parameters could give a clue as to what happened. The Service manual has many examples on how to troubleshoot problems using the snapshot data.

Sorry about the lack of confidence you have in your car. I never owned a new car, so I know this feeling quite well...

I wish I could say that it will run ok for another 100k miles... :)

Peteski