: No spark, in need of assistance.



MiL32T0N3 iNDU2TRi32
03-27-10, 01:45 PM
Hey guys I'm having a problem getting spark in my 1999 DeVille. The car had spark one day then none the next morning, I have replaced the coil pack because my old one had cracks on a couple of the cassettes (have no clue how it happened) still no luck, when I took a test light to the weather pack connectors that run into the coil pack I am only getting power on the drivers side I was thinking this is normal and the passenger side is just signal but maybe I'm wrong? Any advise you guys could give me would be amazing, I would really love to get the Caddy back on the road!!

Thanks in advanced guys!!

Ranger
03-27-10, 03:38 PM
When you say you replaced the "coil pack", what exactly did you replace? The 4 coils or the ICM that they are mounted on?

MiL32T0N3 iNDU2TRi32
03-27-10, 06:17 PM
Both I got 4 new cassettes and the ICM... Sorry for not being clear. Thank you for the reply Ranger!

Ranger
03-27-10, 09:09 PM
The 2000+ engines use ignition "cassettes" that have the coils and ICM mounted in them and are inset into the cam covers. Your engine has 4 coils (I assume that is what you are talking about) mounted on the ICM which is mounted on the rear cam cover. You have no "cassettes". Have you pulled the DTC's?

MiL32T0N3 iNDU2TRi32
03-28-10, 12:26 PM
Sorry about that I was just going off of what my invoice called them, as for DTCs I am not getting any but I also cannot start the car, can the car run a check with the key just in the on position??