: 1994 Northstar, jumpy acceleration, back fires, loss of power at times



mhcapps
03-04-10, 11:34 PM
Hi,

I have a 1994 Northstar and it has started acting up. I have read about the cold carbon problem but this seems to be different. The car has 100k miles and has started to backfire at times, around 30-50mph. It does not do this at high speed and it also makes this same sound at times as it cranks. It normally only makes the sound once, but it looses power and just runs jumpy like a car that is not getting enough fuel. I was going to ask for any suggestions before I start trying to track down and fix the problem.

Thanks,
Mark Capps

thewireman*
03-05-10, 10:56 AM
You should check out this forum... http://www.cadillacforums.com/forums/northstar-performance-technical-discussion/25119-stutter-engine-trans.html

Ranger
03-05-10, 12:21 PM
Also check your fuel pressure.

ponyboyt
03-10-10, 09:18 AM
i am about to tackle the same issues, so instead of making a new thread, mind if i join you?

Doesnt matter if its hot or cold. I stopped at a store for smokes, car was at temp. I was in for maybe 2 minutes, i come out and fire it up, pull out and hit the gas a bit and it -half- bogged. No stall, i actualy thought my ABS kicked in (traction) buit i know thats not it. It was acting like it was -5 degrees out. When i take the car up to 35-40km if i floor it, it kicks down to first and you can hear a couple sputters. If its a backfire, its quiet. I know i have a bad mount, as it does slam kinda hard when it kicks into first. I just replaced the dogbones yesterday. I have newish plugs and wires, less than 30k on them. Plugs are straight from a chev/olds/cadillac dealer. Wires are from an autoparts place.

I was getting O2 sensor codes. P0154 B1S1 insufficiant activity. Replaced the front sensor with another used sensor (this is a test phase, im not buying new parts till i know i need them). That code is gone. P0147 post cat O2 heater performance. <-- that one hardly ever comes up. The last 100km's have been codeless, now i have to wait it out.

Ill check my wires tonight and pull the front plugs. Plugs should be under warenty.