: New to me 07 Escalade



desidon
03-02-10, 07:49 AM
Fist post!!
Hi folks...just picked up this 07 with 11000 miles on it. Got it as a CPO so good for 6 years/100.
Have a noticed a few things
1. Wind noise : Read the forum. Will be taking to the dealer to implement service bulletin.
2. Old Nav disc : Read the forum...will be calling them to see if I qualify for the new nav
3. No volume control in the steering : Looks like this feature is not available in the 07. Can someone pls confirm?

cenman
03-02-10, 08:34 AM
Mine is on the right side of the steering wheel.

desidon
03-02-10, 08:39 AM
Mine is on the right side of the steering wheel.

Do you have an 07? If yes..I may be doing something wrong. I have the SRC button which changes sources, a >1 button that gets you the next station and the + and - buttons which do not change the volume.
What am I missing.

cenman
03-02-10, 08:50 AM
Yes, mine is a '07. I'm not sure if it's +, - on the buttons. I'd have to go out and check, but mine does control the volume.

TSS
03-02-10, 08:57 AM
My 07 definitely had volume control. Try the buttons on the right side, rear buttons. You cannot see them, they are not labeled. They are directly behind the +/- buttons, you "pull" them toward you instead of "pushing". They are on the back side of the steering wheel. I seem to remember those controling the volume on my 07.

Todd

desidon
03-02-10, 10:40 AM
Mine is on the right side of the steering wheel.


My 07 definitely had volume control. Try the buttons on the right side, rear buttons. You cannot see them, they are not labeled. They are directly behind the +/- buttons, you "pull" them toward you instead of "pushing". They are on the back side of the steering wheel. I seem to remember those controling the volume on my 07.

Todd

Sorry folks...my bad. I did locate the buttons. They were behind the main set of buttons on the right and not easily visible.