: 98 deville motor mounts....



undertaker0231
02-23-10, 10:21 PM
Alright guys my motor mounts are worn and how i know this is because im getting the grumbling noise (motor hitting exhaust) now i have a few questions.. are Dea motor mounts any good? found that they cost about $50 at AZ with a limited lifetime warranty. and how many motor mounts are there i know about the two on the top of the motor which pepboys is telling me there bad when i know damn well right that they cant be bad its gotta be the ones on the bottom, so how many are on the bottom and where are they located?

Ranger
02-23-10, 10:42 PM
The notorious mount is the front one. If you have torque struts, I'm surprised that your mount went.

undertaker0231
02-24-10, 08:43 PM
I have no idea I run into every problem known to man, but i got the struts on the top and you said its the one on the bottom...how many are on the bottom? just curious haven't really looked good under there

Ranger
02-24-10, 09:02 PM
The struts are on top. The mounts are on the bottom. The struts prevent the motor from rolling back under torque and tearing the front mount, a big problem on later models that did not use struts.

undertaker0231
02-24-10, 09:16 PM
then why the hell do i have it??? lol

97EldoCoupe
02-25-10, 08:03 PM
I'm going to say that your exhaust is hitting the body brace just behind the catalytic converter. That's a slip-joint exhaust connection. Raise the pipe so it's straight and put a couple of inches of weld on that joint. Also the rubber hangers tend to stretch over time- those are easy to replace.

I really don't think it's a motor mount issue at all, unless you've physically seen that it's broken. I've rarely ever seen one broken. When I got my first 97 Eldo, I looked underneath my car and that front mount wasn't even fastened down to the subframe. All the work was done by the torque struts.

undertaker0231
02-26-10, 05:47 PM
Alright eldo thanks ill check that out the next time i get it on a lift im away right now and that thing was gettin about 32 mpg on the highway at 65 mph idk how but i love it lol

97EldoCoupe
02-26-10, 07:13 PM
Never question fuel economy beyond one's expectations. LOL - just be very, very happy!

My 97 Eldo - 4.0 Aurora V8 in place of the 4.6, 35 miles to the U.S. gallon, 42 to the Canadian gallon. And still as much passing power as any other VIN 9 STS. Go figure. Just a bit slow from the get-go. The mileage is almost worth the trade off of low end torque. Honda owners eat your heart out - we'll be passing you on the highway, AND passing you at the gas station with our nice big fuel tanks..... :D

undertaker0231
03-01-10, 05:10 PM
well guys let me tell you how dumb i feel it wasnt my motor mount 97eldo you were right it was some bracket or piece of metal that was bent it was in front of the resonator i remember one day when the noise started i went up a driveway and something banged hard as hell because my air shocks are completey trashed and it bent half way so when i was accelerating the exhaust was touching that so i bent it back into place and now everything is fine = ) :worship: