: 07 Escalade battery problems



helicopterpilotdoug
02-19-10, 03:28 PM
I just had my 07, which I just bought less than 2 weeks ago, not start after sitting for about a week. I've been ill and finally felt good enough to get out of the house. The doors unlocked normally, instruments came on etc. but when I turned the key to the start position, it made maybe 1 revolution, and quit. Called the dealership, and they are sending someone to fix it, or tow it in. I've been trying to find out info about it on here, but my search did not go through, then you have to wait for 30 min before another search! And I thought the GTO forum was bad. Anyway, is this a problem with these Escalades. I've wondered if others have had ongoing problems with dead batteries.

helicopterpilotdoug
02-19-10, 05:04 PM
Roadside assistance came, and said the battery needed to be replaced, and put in a new one. Hopefully this will take care of the problem.

trashguy
02-19-10, 07:02 PM
read the sticky on adding a second battery, these delco batteries dont
last. maybe try a optima. the search is 30 seconds not minutes i thought.

SouthernCaddy
02-25-10, 02:24 PM
you are correct on both items !!!

Neoex
02-25-10, 04:05 PM
Cadi replaced my 07 battery under warranty 3.5 year after IN-SERVICE. I even admitted to draining it by leaving dome lights on 5 or 6 times. No questions asked brand new battery.

silverws6ta
02-26-10, 09:16 PM
.. but my search did not go through, then you have to wait for 30 min before another search!

You cracking on the x86 PC's that this board runs on ?!? :banghead:

But yes -- definitely look into an Optima -- especially if you are in a variable climate with extremes.