: 98 deville blue smoke and burning smell at high rpms.



undertaker0231
02-10-10, 02:03 PM
hey guys today were having another nor easter up here in philly so i decided to have some fun with the deville in the snow. i went in my alleyway to turn around my car so i can get back up and i got stuck :banghead: when trying to get out of the snow i put it in 1st hit the gas 3/4 backed off kept getting stuck floored it then it starting to smell like something was burning and my exhaust had blue smoke coming out and i do a wots every now and then but i baby it 75% of the time. it was running at about 203 so i wasnt two concerned i just let it idle for a couple mins and got up my driveway but can someone tell me i didnt ruin anything in my motor so i dont panic for the rest of the day?

Ranger
02-10-10, 05:48 PM
Why in the world would you go WOT when stuck in the snow? Are you sure it wasn't your tires burning up?

undertaker0231
02-10-10, 06:24 PM
ughhhhhhhhhhhh i dont know now that i think about it lol but i hope it aint any seals or anything like that

97EldoCoupe
02-10-10, 07:49 PM
Block half seals spit out oil at higher revs if they're on their way out. Don't spin until you're un-stuck- you'll ruin a few things, transmission being #1. save yourself some money and problems and get some help from a 4x4 and a tow rope.

97EldoCoupe
02-10-10, 07:53 PM
If nothing else give it a nice break between short burst of trying to spin to freedom. Older non-electronic vehicles seemed to like careful "rocking" to get out of a hole- but electronic transmissions don't shift fast enough to do this.

undertaker0231
02-10-10, 11:01 PM
thank you 97eldo.... i just like the sound of the monster northstar it does pretty well in snow but today is just forget it.... next time ill take it easy lol