: Coolant tube question



bigds01
01-30-10, 04:25 PM
On our 94 sls, the coolant tubes were completely shot. Does anyone know where I can get a replacement set? Can I just use rubber hose instead?

cl1986
01-30-10, 05:11 PM
i believe krash used some rubber lines as a temporary fix.

I asked your same question last week, the only answer i got was to use tubes off another engine that arnt corroded.

I ended up just wire wheeling mine and painting them, they looked really crappy but were actually solid after getting the flakes off. My other engines lines looked worse than these, so it was my only choice.

Krashed989
01-31-10, 04:19 AM
You can see the two red heater hoses back there. My car was like that for about 4 years with only 1 problem:
http://i29.photobucket.com/albums/c296/Krashed989/100_0914.jpg

This was the problem. The heater hose was too close to the EGR tubing and eventually burnt through:
http://i29.photobucket.com/albums/c296/Krashed989/100_0905.jpg

This was how I fixed it:
http://i29.photobucket.com/albums/c296/Krashed989/100_0903.jpg
http://i29.photobucket.com/albums/c296/Krashed989/100_0904.jpg

cl1986
01-31-10, 11:29 AM
LOL, 4 years!! i thought you said that was a temporary fix LOL haha

Submariner409
01-31-10, 02:16 PM
Any ideas as to how many skrillion feet of red heater hose is running around out there.......................?

jeffrsmith
02-02-10, 06:43 AM
Any ideas as to how many skrillion feet of red heater hose is running around out there.......................?

Probably about a skrillion :duck:

tateos
02-02-10, 08:47 PM
Nice pics Krashed, and a nice solution, too - that's what I would do too

env05
02-13-10, 12:30 PM
im on my way to azone to buy some heater hoses myself . im 99.9% sure the clogged tubing is my problem .thnx u much !!!