: Need Help Reprogramming FOB's: nothing is working



pj96ss
12-30-09, 08:21 PM
:(
I'm trying to reprogram a new FOB to the car since one of the originals (FOB 1)was cracked and taped together. I followed the steps on page 2-8 first since FOB 2 was perfect. Didn't work. Tried again to no avail. I figured that since I have some time and 3 perfect FOB's, I'll try the directions on starting on page 2-9. I've been thru the procedure now twice and nothing. I can't start the car, nothing. Following the directions, everything goes as the manual says up till step 14. After the 3rd 10 minute wait, step 14's message comes up and stays up for about 5 minutes. The DIC goes blank after that and NOTHING!!! I'm dead in the water!!! Any ideas/tips/tricks? Am I an idiot and missing something? I did go to public skool so I could have missed something (remember, reading is phundamental).

Thanks,
P.J.

CIWS
12-31-09, 10:10 AM
A stupid question, but won't the dealership do this for you ?

Indyblue98
12-31-09, 12:27 PM
:(
I can't start the car, nothing.
I'm dead in the water!!!

Thanks,
P.J.

Its been a year since i've done this.
My car is a 2007 but had one the newer style remotes.
Of course my manual is for the 2007 but it also shows both versions of the remotes.

I think after you do the 14 steps, that clears the cars memory , next you actually go thru the 8 step programming .

:confused:
I bought another remote and when trying to program it
i remember getting stuck for a while with a car that wouldn't start, just can't remember exactly what i did to get it going again.

But i only had the manual for directions so it is possible.

Keep us posted once you get it going please... who know I might need to do it again when the battery dies.:duck:

pj96ss
12-31-09, 01:59 PM
If I can't figure it out by Monday, I've got Cadillac Roadside Assistance towing it to the dealership. Step 14 did clear them all big time. The guy from Roadside Assist. said to put the FOB in the slot and with brake pedal pressed, push the start. When I told him that it's just saying No FOB Detected, he immediately said it's a computer problem and the car should have recognized the FOB (sounded like the 3 10 minute waiting periods is nothing more than a deterent). I'll try a few more times but Monday morning she'll go onto a flat bed.

P.J.

silverws6ta
12-31-09, 04:07 PM
If I can't figure it out by Monday, I've got Cadillac Roadside Assistance towing it to the dealership. Step 14 did clear them all big time. The guy from Roadside Assist. said to put the FOB in the slot and with brake pedal pressed, push the start. When I told him that it's just saying No FOB Detected, he immediately said it's a computer problem and the car should have recognized the FOB (sounded like the 3 10 minute waiting periods is nothing more than a deterent). I'll try a few more times but Monday morning she'll go onto a flat bed.

P.J.

Restart the process, and place the '1' fob in the little 'cubby hole' inside the center console that you use if the remote goes dead and enables you to start the car; while you go through the process and let me know what that does for you!

pj96ss
01-01-10, 03:03 PM
Went thru the process again. Got to step 14 and it just read 'Ready for FOB 1' and the DIC went blank after about 4 minutes. What is wrong? How about shifting out of Park and into Neutral? With the electronic shift control, how do you shift with no power (due to no FOB recognized).

I'm bummed, at least the weather is crappy and I'm driving my truck anyway.
P.J.

inurok
01-02-10, 07:49 AM
My car came with 4 fobs 2 programmed and 2 not? I guess I will see if the dealer will program all of mine at once since I still get the fob not detected message every once and a a while

Bee iLL
01-04-10, 11:37 AM
Went thru the process again. Got to step 14 and it just read 'Ready for FOB 1' and the DIC went blank after about 4 minutes. What is wrong? How about shifting out of Park and into Neutral? With the electronic shift control, how do you shift with no power (due to no FOB recognized).

I'm bummed, at least the weather is crappy and I'm driving my truck anyway.
P.J.

Im sure you have checked this, but thought I would throw it out there anyways just in case. Did you install or check the battery level in the new FOB?

pj96ss
01-04-10, 12:07 PM
Just got back from the Cadillac dealer. Friday, I tried the process again with no luck. The dash had the battery light come on. Put the charger on it and the battery was around 7% (found in the manual that the light will go on if less than 10% charge). Charged it up. Re-went thru the process. This time it said it programmed FOB 1 (which was the original fob 1 for the car). I continued to insert FOB's 2/3/and 4. It didn't like FOB 4 (3 & 4 were bought on the internet). Afterwards, only FOB one was recognized. Tried to start the car and got nothing but 'Starter Disabled Theft Prevention' or something like that. Wouldn't start but there was power on the Accessory setting to shift to neutral. The car sat all weekend. Tow truck was about to pull in the driveway when I went out and tried to start the car. No power. Got my trusty charger out to give her some juice so I could shift into neutral. Low and behold, it allowed me to start the car!! The theft prevention must have a time delay. Drove the car to the dealer. Gave them all 4 FOB's. Came back later saying that the battery was really low and only 2 of the FOB's were good. Funny thing is, one of the FOB's that they said is bad, was the original #1 for the car. The original #2 programmed as well as a #2 that I bought on the internet. At least the car is back running. I've got 2 FOB's that they say are bad (1 original and 1 OEM from the interned). I'm done screwing with it and will have to spend time resetting everything.

P.J.