: Strange Things Happing



shaunp05
08-07-04, 05:54 PM
I was driving up the street then I lost power for a second then it came back,
i drive a 93 STS with a N*, I have been wandering does all the I.A.C valves
make a noise when there resetting when the new or is only, as it gets older as mine is doing that,
IF the fuel pump is on its way out could it fail one time or keep running
and give problems once in a while ?
I checked my codes and nutining came up that would relate to it failing ...
I mangered to drive home and it never failed after that... I tried to cause the
problem and it never came back ????

please help me out

caddyshack24
08-07-04, 05:59 PM
Thats not cool. did you have the A/C on at the time? Our 1993's dont have an I.A.C .. we have an ISC. What happens is when you let off the gas, the throttle returns to 'idle' and if the motor has failed, it cant hold it at the needed angle to keep the engine running. With the A/C on, the pcm adjusts the idle to compensate. You left off the gas and it will stall, but usally quickly recovers. that might be the power outage your experiencing. How is your idle in park? Pretty erratic? It should be around 650 RPM. You can check by looking at PCM data value: PD11

The part is $120 from a local dealership, $70 from most other places. Once you replace it, you'll have to an 'idle learn procedure' .. might as well clean the TB, EGR and PCV system while your at it. Let me know if i can be of help.

shaunp05
08-08-04, 12:08 AM
I didnt have the Air on at that time, and this occured when I was going thorugh a traffic light and I was just about to floor my baby...
then it died down like a flat spot on a Carb??? but it never stalled
it would stay running but every time I reved it up it wouldnt pick up ???
and it Ideals normal around 700 no up or down movements ?

caddyshack24
08-08-04, 12:19 AM
That sounds like a fuel problem to me.. im no expert though.
The idle sounds healthy. My thoughts are EGR, where it re-circulates exhuastive gas back into the engine.. maybe to much. or fuel injectors that didnt open fast enough and to much air got mixed in. Hell, could be anything. You cant reproduce it? kinda lacking any details to go on. From what i gather, it kinda cuts out when you start giving it gas real fast?

You're probaly thinking, why are you helping me if you dont know anything. lol
Thats how we learn, i have the 93' with northstar. your probs are my probs. :coolgleam

Ranger
08-08-04, 09:23 PM
I agree with the EGR for starters. Clean it up and see if that helps. As far a fuel pumps go, I have seen some die a sudden death and others linger and die slowly but start with the easy stuff first.