: Aux-in iPod "on screen" controls setup DVD Nav system



Ludacrisvp
12-12-09, 01:02 AM
I just wanted to show off this setup I have finished in my 2002 DTS.

The box on the left that is too bright white to make out in the pics is the spot that shows your "Now Playing" information and album art.
My TouchPro2 camera doesnt like taking pics of the bright nav screen.

http://www.cadillacforums.com/forums/attachment.php?attachmentid=54431&d=1260597301

http://www.cadillacforums.com/forums/attachment.php?attachmentid=54429&stc=1&d=1260597317

http://www.cadillacforums.com/forums/attachment.php?attachmentid=54430&d=1260597301

I purchased the following equipment to pull this off:
Aux AV input adapter harness for Bose Factory Nav from Jason (CadillacSTS2003)
Tekkeon NavDock Home Media Center with on screen navigation (http://www.newegg.com/Product/Product.aspx?Item=N82E16855998640)
Scosche DC portable navigation charger with 5v 2amp output

So I setup my car with the aux audio video input so that I could have my iPod in my caddy since I was used to having it perfectly integrated in my 2001 Monte SS with a Kenwood 7" double Din nav system.
I dont drive the Monte in the snow and I missed not having the iPod.

When I got the aux cable I just used an iPod video composite cable to listen to music but I didnt like the lack of charging of the iPod and no information on the screen.

So I purchased a DLO HomeDock HD for almost $200 that I was going to use in the car because it used a 12vdc power source and was the only on-tv ipod navigation I could find. It was junk, couldnt read my iPod more than 25% of the time, and when it did it took about 5 mins to load up to have music play. Did a firmware update on the homedock and it was still crap, returned 2 days later.

I then found the Tekkeon NavDock for half the price and the reviews on it were great. I have installed it today and it is hands down 1000% better.

The NavDock uses a 5vdc 1.5amp power source, so I couldn't just hardwire the unit in like I had planned with the HomeDock. So knowing that USB powered devices are 5vdc and some usb car chargers for cell phones put out 5vdc 1 amp. I used one of them and made my own cable (USB to 5vdc plug) but there was way too much alternator whine in the sound.

I then went to walmart in search of a different usb car charger that had some more power and hopefully less whine. I found the replacement portable nav chargers for TOMTOM and Garmin and they output the 5vdc that I needed and were 2 amps. It also came with the right cable adapter to replace the cable I had made.

Plugged it in and it was pure bliss, no whine, no buzz, navdock powered up perfectly and I was on my way.

Perfect onscreen information and it comes with a very handy remote control that is very functional.

The wires are hidden under the console and are not interfering with the floor shifter, for right now the dock and iPod will sit in the little cubby in front of the shifter until I get my dock extension cable then all that will be there is the dock and the iPod will be hidden from view.

chazglenn3
12-17-09, 01:48 PM
That's awesome...thanks for the writeup! Did you have to use the Apple A/V cable or an aftermarket? I know that with the 3.0 firmware update Apple made it so that aftermarket cables won't display the video. I hate the thought of buying the Apple cable for $50 but this would make it worth it.

Ludacrisvp
12-18-09, 04:47 AM
For testing purposes before the NavDock arrived I went to RadioShack and picked up a generic brand of the composite iPod video out cable through the 30 pin dock connector and it worked just fine for video out.
The NavDock allows for out put of either Composite or S-Video for use in a home entertainment setup.
It comes with the composite cables needed so you don't have to buy an Apple cable.

I however don't have the newest iPod out there I am using the 80gb "classic" silver iPod and do not have a touch or iPhone to test out video compatibility with them.

chazglenn3
12-18-09, 08:43 AM
Thanks. I have the NavDock on the way. Is this the correct adapter?

Ludacrisvp
12-19-09, 10:10 PM
That looks like it might be the HOME charger, hard to tell from the little pic though.
It looks right, just make sure its for the CAR if you plan on doing the same setup I have in the car.
If you plan to use it in the house then it does come with a 115vac power adapter for home use.
Charger info from Scosche Site (http://www.scosche.com/products/sfID1/337/sfID2/318/productID/1641)
Here one is on Amazon.com (http://www.amazon.com/Scosche-GPSCHRG-Universal-GPS-Charger/dp/B001JQMFUC)

mrgoodbar67
12-21-09, 12:30 AM
Nice bro.

I did this 1 yr ago or so with my 120 gig zune..really f'n clean set up too.

eyekandyboats.inc
12-21-09, 02:28 PM
i have a question. I have a NAV unit out of a 2002 and i can not for the life of my find the onscreen AUX button??? what gives
i have AUX in video in but i cant find the AUX button. could you explain how to get there?

chazglenn3
12-21-09, 06:24 PM
Select the DVD hard button and then the AUX button should be available on the screen. If the button stays Breyer out then you have a signal problem.

eyekandyboats.inc
12-21-09, 06:32 PM
it does nothing once i click the DVD button it either starts to play the DVD or says " no dvd inserted"
what firm ware do you have?
I have 3.10 what do you have?

eyekandyboats.inc
12-21-09, 06:46 PM
do you have a firmware CD to load the inital firmware?
would you be able to send it to me and see if the AUX feature changes in firmware files?

chazglenn3
12-22-09, 07:57 PM
The firmware I have is also 3.10 so I don't think the issue is with the firmware. It still sounds to me like the wiring harness isn't pinned out correctly and the aux signal is not getting into the unit.

Ludacrisvp
12-22-09, 11:19 PM
If your head unit doesn't sense audio or video on the aux channel it will not allow you to access it.
It has to "see" that there is a piece of equipment attached to the input before it will be something you can use.
Press DVD hard button - you don't need a disc in of any kind if you don't want to
if you have a DVD in stop it from playing or put the car in gear and it will go back to the main screen where you can see
"AUX/VD" greyed out if you don't have anything connected

eyekandyboats.inc
12-23-09, 02:26 AM
OHHHHHHHHHHHHHHHhh
I SEE IT
thanks guys! LOL i cant get to that menu unless i have a DVD inserted..
i will hook up my I pod and see how she works tomorow.

mrgoodbar67
12-24-09, 01:31 PM
how but a vid of it wrking? ill post one of mine and we can battle for respect.......too me thats worth alot more!

Ludacrisvp
12-26-09, 12:58 AM
Ya, I could post a vid of it working. It may take me a bit to get it done though, its been really shitty weather here (lots of snow) and with the Holidays I've been kinda busy.

eyekandyboats.inc
12-26-09, 10:28 AM
hey guys i will get a video of it working today for you

eyekandyboats.inc
12-26-09, 05:49 PM
http://www.youtube.com/watch?v=FburjjpWXQw

mrgoodbar67
12-27-09, 06:23 PM
i wasnt talking about a vid of the nav head unit at work.
i was talking about the ipod vid onscreen and the zune vid onscreen.
but thnx anyway.
wuts that second code u put in and for wut?

Ludacrisvp
12-27-09, 10:29 PM
i wasnt talking about a vid of the nav head unit at work.
i was talking about the ipod vid onscreen and the zune vid onscreen.
but thnx anyway.
wuts that second code u put in and for wut?

He first puts in 1791 for in motion override then 6497 for diagnostic mode.
He has an 01 Deville but a nav system from a newer deville 03 or newer.
Our code for diagnostic mode is 1971.
Uploading my vid to you tube in a little bit of the iPod on screen.

Ludacrisvp
12-27-09, 11:17 PM
http://www.youtube.com/watch?v=hj2DyI3E77U

mrgoodbar67
12-28-09, 12:22 AM
cool.
wut u did with the ipod and the NAv DOck is wut i FIRST did with my Zune about 1.5 yrs ago.

-i bought the Zune AV Dock http://www.zune.net/en-US/products/z/zunedockpack/details.page/
-hooked it up my aux connections made by cadillacsts2003, then
-connected my Zune to it as you did ur Ipod to the NAv Dock &
-on zune settings i switched the video out feature to ON (zune is able to display all zune onscreen content (menus, etc) to tv from factory
- and use Zune dock remote to control the zune.

i didnt make a vid of that setup back then, but heres one just like it using a Pioneer headunit instead of the cadi nav.


http://www.youtube.com/watch?v=FXkAe8owEXQ

everythings was the same as above on my set up xcept I didnt choose the AV1 option...since i had the cadi nav instead i chose DVD, then AUX image

here it is in action with onscreen menus


http://www.youtube.com/watch?v=fb89Q5Exxic

even after this whole setup i wasnt satified becasue it didne look "STOCK enough", so then i found this.

http://www.soundgate.com/index.php?request=product.details&categoryid=309&productid=629&usereferrer=1&

& this

http://www.soundgate.com/index.php?request=product.details&categoryid=309&productid=634&usereferrer=1&

its what i now use. now no wires, docks, or anything is visible.
it all looks completely stock.
the wired remote controls everything just like the zune pad does.
i installed the remote into the center armrest and now looks like a bmw armrest dvd/radio/nav control.

looks f'in sweet.
ill post a vid 2morrow. my cam was low on battery.
ull see what i mean.

mrgoodbar67
12-29-09, 01:15 AM
here it is fellas....as stock as it gets.

http://www.youtube.com/watch?v=Rn-Yw_cLe08"]http://www.youtube.com/watch?v=Rn-Yw_cLe08

my zune hooked up to my nav..seamlessly

Ludacrisvp
12-29-09, 03:03 PM
Hey, that is definitely a nice setup. If I had a zune instead of an iPod I would have certainly followed your lead there on making a good zune setup. The iPod TV out only sends out the video information when playing a music video or movie, for some unknown reason they will not output any menu information like the zune does.
I bought a dock extension cable that I had planned on using to hide the navdock and extending its IR sensor into the dash somewhere but the cable I got doesn't do anything but charge when connected to any dock that I have. If I hook it up to the sync cable of a pc or mac then it works? strange. I have 3 iPod docks that I tried it on.
So the plan is this summer when its not freezing out is to make a clean setup like you have.
I wish that the DLO HomeDock HD would have worked because it uses an RF remote control instead of IR so I could have hid it anywhere.
With your rear seat entertainment have you thought of trying to add a second wired remote to the zune and installing another remote in the fold down armrest in the back seat?

mrgoodbar67
12-29-09, 05:18 PM
Hey, that is definitely a nice setup. If I had a zune instead of an iPod I would have certainly followed your lead there on making a good zune setup.

ya i know. this set up is better for zune but ur setup is better for ipod.
your set up is very nice though. i would follow ur lead if i had an ipod. the soundgate setup will only allow audio out and video/ audio out for movies. no menus etc.


The iPod TV out only sends out the video information when playing a music video or movie, for some unknown reason they will not output any menu information like the zune does. I bought a dock extension cable that I had planned on using to hide the navdock and extending its IR sensor into the dash somewhere but the cable I got doesn't do anything but charge when connected to any dock that I have. If I hook it up to the sync cable of a pc or mac then it works? strange. I have 3 iPod docks that I tried it on. So the plan is this summer when its not freezing out is to make a clean setup like you have.
I wish that the DLO HomeDock HD would have worked because it uses an RF remote control instead of IR so I could have hid it anywhere.


the menu output is what i like about the zune...along with the wireless zune to zune transfer and customizable zune background. im sure youll find a way of making it look seamless and hidden.


With your rear seat entertainment have you thought of trying to add a second wired remote to the zune and installing another remote in the fold down armrest in the back seat?

you know...i thought about it. i can easily get a head phone jack splitter connect it to the zunecore brain. and then connect to remotes to the splitter since the remcore connectors are 3.5 mm. i gotta see if itlle work though.

chazglenn3
01-07-10, 07:36 PM
I have my NavDock and power supply...just need to find time to get it installed. Ludacrisvp, did you ever decide on a permanent location for the NavDock?

chazglenn3
01-10-10, 07:08 PM
Well crap. I went to Walmart and bought the Scosche GPS charger and set everything up. It worked as described, but I still have the terrible alternator whine. That, combined with nowhere to really mount the unit has led me to decide to not install it in my car. I took the charger back to the store and will put the NavDock up for sale.

eyekandyboats.inc
01-10-10, 09:04 PM
how much you want for it ?

mrgoodbar67
01-11-10, 05:56 PM
ok so how can HE or I get rid of the whinning noise...I have that too.

eyekandyboats.inc
01-12-10, 04:05 PM
if you are refering to the reverb wine you hear in the speakers when using the dock. sadly that is due to the amount of connectors and electrical equiptment that is in the car. it is all in such close proximity and causing massive rF noises.

N*Caddy
01-12-10, 09:21 PM
You can build a filter using an inductor (serial connection with the load) and a capacitor (parallel connection with the load). The inductor looks like a mini-transformer (you can find one inside the car HU for example – wreck yard and grab one) and as for the capacitor… 200-500 uF @ 16V or higher (for longevity use one rated for 32V) buy new (Radio Shack).
Possible to find one already build (or as a kit) to an electronics hobby shop.

chazglenn3
01-14-10, 10:42 AM
how much you want for it ?

I will let it go to a fellow supporting board member for $60 shipped.

tshbzz
07-23-14, 10:19 PM
hi it looks just like what want to do with 05 deville non bose navigation hu will i be able to .tshbzz05cadillacdeville