: 2001 Catera ABS Module



BossLady
10-13-09, 12:09 AM
Okay so I am still battling with my ABS module! I had it repaired by modulemasters and had my friend re install it. Well It didn't make the TC Check Engine and ABS lights go off...and Ive tried multiple times to get in there to check the connections because I am almost positive that is the problem. I have contacted modulemasters and they say if the wiring connector isn't seated in there snug it could definitely be the problem...that damn thing is so hard to get to...can anyone tell me how the connector on top (the big one) is supposed to fit snuggly in there? Does it slide on or push on or..? There is absolutely no room to try and slide it on there. And so since this isnt working it seems to be messing with the transmission..its not shifting as smoothly as it should and a few times the "S" light has come on and started blinking, like the tranny skipped gears cause when I come to a stop it has very little power when I try to go again...although if I turn the car off and back on it runs normally. I'm sick and tired of this pos and I dont trust auto shops to fix it! :bomb: Help! It's a Bosch 5.3 ABS module fyi

pedrazamarcos
10-13-09, 12:48 AM
I would start from the begining,Disconect battery,connect everything back the way it goes,put your battery back,restart/drive if necesary till lights(ABS or whatever you getting,then check for codes,Go from there.If you post codes i may be able to help.

BossLady
10-16-09, 05:07 PM
Well good news! I was able to find a picture of the bosch 5.3 module and finally found out how the connection goes on there...you have to pull out this plastic sliding tab then place it on and then push it back and it fits in there securely, Ill post the picture because it really helped me out. So now my speedometer works! The abs and tc lights went off! :D The only light that is left on is the check engine light, not sure why, is it possible it could turn off after driving it for a bit? I did disconnect the battery during the process already. Any input would be helpful! Thanks! I'm super stoked!!
http://img11.imageshack.us/img11/1926/boschabsremoval2.th.jpg (http://img11.imageshack.us/i/boschabsremoval2.jpg/)

pedrazamarcos
10-17-09, 12:49 AM
I would start from the begining,Disconect battery,connect everything back the way it goes,put your battery back,restart/drive if necesary till lights(ABS or whatever you getting,then check for codes,Go from there.If you post codes i may be able to help.

looks like I was right when I said "connect everything the way it goes"

BossLady
10-17-09, 08:03 PM
sure if you want to take credit for it...though that advice wouldnt have helped me, it was the picture I found of how the connector is attached that helped.

Greg Zeboray
11-07-09, 08:22 PM
BossLady, did you have trouble with power steering too sometimes, and was the cruise control not working? Anyway, I have the same problems as you - pluse those I just mentioned. Did you get the codes on the check engine light? Mine are 500 (Speed Sensor), 2108 (Lost communication with ABS Module), and 1700 (TC Module).

Also, did the TC, ABS, and speedo problems go away and come back from time-to-time? Mine does and drives me crazy.

Hope I hear back. Thanks

BossLady
11-30-09, 01:47 AM
Hey man sorry it took me so long to get back to you. I bought my catera used and got it for a good price because the owner couldn't deal with it anymore. Yes when I first got it the speedo and lights would come on and then go off like it was normal but not too long after all the lights would stay on. I would say power steering was affected yes, not sure about CC as I never tried that. But I went through modulemasters.com and they repaired it and after some battle with reinstalling it everything works great! I didnt use the codes I think I just did a lot of research on it and this sounded like the problem I was having. It definitely sounds like the ABS module is going out..try to go to module masters and they have a part where they ask you questions to find out whats wrong.
Good Luck! Let me know if you fix it!

Greg Zeboray
12-01-09, 12:59 AM
Are you sure the address is modulemasters.com? I just went ther and it was a computer repair place (?)

BossLady
12-02-09, 09:37 PM
Are you sure the address is modulemasters.com? I just went ther and it was a computer repair place (?)

Ah modulemaster.com No s Sorry!

Jim Wyte
01-04-10, 06:56 PM
I am having the exact issue. Where on the car will I find the ABS Module? Did you have modulemasters repair the unit and if so, what was the cost?

BossLady
01-28-10, 10:48 AM
I am having the exact issue. Where on the car will I find the ABS Module? Did you have modulemasters repair the unit and if so, what was the cost?



Sorry I do not check this as often as I should! It cost under $200 as I recall, you have to take the module out yourself and send it in to them and they repair it if it's broken. You pay for shipping I believe and if it turns out that wasn't the problem they will send it back to you and all you had to pay was shipping. It was a pain in the ass to get that thing out but if you have the patience and are willing it's worth it! My Catera is still doing great and no lights have come back on or anything. Location of it...its on the drivers side engine compartment kind of hidden deep down. I would go to modulemaster.com and you can click through there and they "try" to tell you how to remove it. Let me know if you need anymore help I will check back more often! Oh and yes you can still drive the car once the module is out you just have to put plastic wrap and tape around the exposed area so no dirt/water etc get into it. Turnaround with modulemaster was great and they are very helpful! Good luck!

DJV8524
03-29-13, 08:01 PM
Well good news! I was able to find a picture of the bosch 5.3 module and finally found out how the connection goes on there...you have to pull out this plastic sliding tab then place it on and then push it back and it fits in there securely, Ill post the picture because it really helped me out. So now my speedometer works! The abs and tc lights went off! :D The only light that is left on is the check engine light, not sure why, is it possible it could turn off after driving it for a bit? I did disconnect the battery during the process already. Any input would be helpful! Thanks! I'm super stoked!!
http://img11.imageshack.us/img11/1926/boschabsremoval2.th.jpg (http://img11.imageshack.us/i/boschabsremoval2.jpg/)

This single picture has helped soooo much, thank you for posting it.