: dvd head unit w/bose system



DonRSD
09-10-09, 03:41 PM
hey all
i just installed a kenwood ddx512 dvd head unit into my 2002 deville dts

i have the stock head unit tucked away in the trunk.

my question is that when the kenwood was installed the audio shop had to rewire my car.....but the subwoofer does NOT WORK

is there any way to have the stock subwoofer (rear deck) start working?
or do i need to buy a new amp and run rca's from the kenwood to the new amp then speaker wire to the sub?

id like to use the bose amp and the stock subwoofer but i dont know if its possible

DonRSD
09-11-09, 11:31 AM
any help???

Dev-ille
09-11-09, 12:14 PM
You need a data interface for the bose factory amp to work as intended. 100% doable, it just sounds like they never installed one. You didn't mention it, but does your Onstar work? Steering wheel controls active? Sub 100% working before the install?

What probably happened was the shop you went to either:

1) Didn't have the correct interface for your bose system, or didn't know the car needed one, or didn't want to scare you off or lose the sale to you by adding another $150 interface (@ retail).

2) Gave you two choices cost wise and you went with the cheaper one (I'm not accusing you of this, I've just seen it happen countless times)

3) Are just not bright enough to know the proper way to replace a radio in your Deville and not lose any of the bose or Onstar features, but did know how to rewire your car by tapping into all the speakers at the factory amp (besides the sub).

Did the shop even ask you if your Onstar was active? Did they give you a choice of adding the interface or not? Did they mention that the sub wouldn't be on after they rewired the car? Did they even mention that they were going to rewire the car?

If they didn't, then that was unprofessional of them. They should have fully gone over what was going to be done and what would and wouldn't be active when they finished (assuming that they even know/knew).

If you don't mind me asking, what shop was it?


A few different interfaces on the market will do what you want, but these two are what I deal with most, PAC being the best (imo) from what I've used:

PAC OS2-GM32
Metra Axxess GMOS-06

These will keep the Onstar active, and allow you to use the factory bose amp.

DonRSD
09-14-09, 01:28 PM
You need a data interface for the bose factory amp to work as intended. 100% doable, it just sounds like they never installed one. You didn't mention it, but does your Onstar work? Steering wheel controls active? Sub 100% working before the install?

What probably happened was the shop you went to either:

1) Didn't have the correct interface for your bose system, or didn't know the car needed one, or didn't want to scare you off or lose the sale to you by adding another $150 interface (@ retail).

2) Gave you two choices cost wise and you went with the cheaper one (I'm not accusing you of this, I've just seen it happen countless times)

3) Are just not bright enough to know the proper way to replace a radio in your Deville and not lose any of the bose or Onstar features, but did know how to rewire your car by tapping into all the speakers at the factory amp (besides the sub).

Did the shop even ask you if your Onstar was active? Did they give you a choice of adding the interface or not? Did they mention that the sub wouldn't be on after they rewired the car? Did they even mention that they were going to rewire the car?

If they didn't, then that was unprofessional of them. They should have fully gone over what was going to be done and what would and wouldn't be active when they finished (assuming that they even know/knew).

If you don't mind me asking, what shop was it?


A few different interfaces on the market will do what you want, but these two are what I deal with most, PAC being the best (imo) from what I've used:

PAC OS2-GM32
Metra Axxess GMOS-06

These will keep the Onstar active, and allow you to use the factory bose amp.

thanks for the detailed reply

they told me 'your onstar & steering wheel controls for the radio wont work'
that i dont mind as i never use the steering wheel to control the radio

the 1st time they hooked the dvd/radio up (kenwood ddx 512) they completly disconnected my stock battery.....i had to go back for them to re connect the stock radio and hide it in the trunk

my subwoofer worked with the stock radio, but ever since they installed the new dvd/radio it hasnt worked.
when i brought the car back to get the stock reinstalled in the trunk they tell me 'its a 50-50 chance it will work'

plus NOW my passenger heating/cooling doesnt work....it only reads the temperature of the main ac control. if a passenger gets cold i have to in turn raise the main ac control for that side and the rest of the car to get hotter
AND
the rear ac unit for the rear passengers only 'vents' i guess.....its hot air no matter the hot/cold setting its set on

i need some help with this as its frustrating.
i also may just go back and have them rip everything out and go to another dealer......what a crock.

but if i can fix the sub not working & the ac controls then im good to go

SPreston2001
09-14-09, 03:06 PM
Yeah go and get your money back right now! That shop obviously doesnt have experience with Cadillac Bose systems. Call around and find a shop thats familiar with Cadillac Bose installs. When installed correctly everything should work just as it did before.

Dev-ille
09-15-09, 12:28 AM
thanks for the detailed reply

they told me 'your onstar & steering wheel controls for the radio wont work'
that i dont mind as i never use the steering wheel to control the radio

the 1st time they hooked the dvd/radio up (kenwood ddx 512) they completly disconnected my stock battery.....i had to go back for them to re connect the stock radio and hide it in the trunk

my subwoofer worked with the stock radio, but ever since they installed the new dvd/radio it hasnt worked.
when i brought the car back to get the stock reinstalled in the trunk they tell me 'its a 50-50 chance it will work'

plus NOW my passenger heating/cooling doesnt work....it only reads the temperature of the main ac control. if a passenger gets cold i have to in turn raise the main ac control for that side and the rest of the car to get hotter
AND
the rear ac unit for the rear passengers only 'vents' i guess.....its hot air no matter the hot/cold setting its set on

i need some help with this as its frustrating.
i also may just go back and have them rip everything out and go to another dealer......what a crock.

but if i can fix the sub not working & the ac controls then im good to go


Ouch. "Your Onstar and steering wheel controls for the radio won't work" This line tells me that the shop you were dealing with is populated by people that don't have any business touching a car ever again. I really hate it when I hear things like this because it gives shops a bad name, although some get it deservedly. I mean anyone can get the proper interfaces to do the job, and they didn't even try and do things the right way. Which would have in turn made them more money, made their job easier and them more professional. If they're that bad (and it sounds like they are) then this is not someone that I would want to take my car back to "rip everything out".

As far as the AC controls, it's tough to say without looking at it. I can only guess what they may have done to make your ac do that. They may have tried to get their switched power at the ac since it's so close, but again, that would just be a guess.

I'm not really sure why they chose relocating the stock radio because the proper interface would have done the job properly without having your radio live in your trunk. I believe your stock sub should have worked with the radio relocate but I'm not positive as I always use the interfaces.

I'd do a lot of research on shops in your area before taking it to just anyone that say they can do the job this time. Hopefully they didn't do any serious damage, but i don't think I'd try and talk to them until I found out exactly what they did, if anything (I can't really say they did something without seeing it, but this does sound install related). If you give me your area, I can recommend some reputable shops nearby. Do your own research though, talk to a few and get a feel if they know what they're talking about, read reviews, ask around, etc... Shop for quality over price. I'm not saying get raped but I am saying you want to get it done right and sometimes that means paying a little more. Getting it done right the first time would have saved you from having to pay someone else to do it again, and all the additional aggravation. I'm not saying it's your fault, far from it, it's theirs on multiple levels from the sound of it.

Good luck

DonRSD
09-15-09, 09:53 AM
thank you for the prompt reply.

i called a reputable shop down here yesterday (sound blazers)
i told them where i got the radio installed (sound of sunrise) and this guy HATES the owner.

as far as my AC controls.....im going to put the stock radio back in this weekend and if everything works, im bringing the car back to have them give me my money back.

if when i put the stock radio back in im also looking for the GMOS thingy.....as i understand it is needed.

i also found out my tire pressure doesnt work on the dashbopard.

this guy is going to owe me $155 back for my install.

Dev-ille
09-15-09, 04:33 PM
$155, and they didn't even give you the chance to have it done right. Pathetic.

Good luck getting your money back, although you might have to give up a little something for at very least the parts involved that you'll still be able to reuse (kit + antenna adapter is the only thing I can think of).

Let us know how it goes.

DonRSD
09-16-09, 10:17 AM
$155, and they didn't even give you the chance to have it done right. Pathetic.

Good luck getting your money back, although you might have to give up a little something for at very least the parts involved that you'll still be able to reuse (kit + antenna adapter is the only thing I can think of).

Let us know how it goes.

screw them. im not going back there ever again.

im calling around my area today
coral springs, fl (suburb of fort lauderdale) to see what can be done.
i may just go the route of 'hey man, uninstall this and install it correctly' and pay whatever $$$ thewy charge

my concern is making sure the passenger side ac heating/cooling temperature guage works and the back ac vent doesnt blow out hot air