: 2001 Catera ABS Module Problems



BossLady
09-07-09, 06:09 AM
Okay so I have had my ABS module replaced or rather I sent it into modulemasters and had it repaired and I had my friend install it for me...and the TC, ABS, Check Engine lights are still on and the speedometer doesn't work. I remember reading that the ECM may have to be reset if this is so how do I do it? I would love to get these damn lights off of the dashboard and perhaps see how fast I am going would help as well! :thepan:

BossLady
09-10-09, 06:32 PM
So is it going to harm my car if I drive around with the ABS module not functioning properly? I know it affects the way it drives and possibly the transmission. Do I need to reset my ECM or should I just be able to plug the module in and it works? I am going to try and get under there and feel the connections because I have a feeling it may not be totally connected but doing that without taking the damn thing apart is kind of a bitch AHHH anyone have input? I know a lot of people have looked at my post! :bonkers:

BossLady
09-13-09, 01:24 AM
I was trying to look at the connections on it today and the one that is on top, the big long one with all the wires, seems loose to me. Like is it supposed to snap in because if I lightly pull on the wires it just comes off. Also does anyone have pictures of what the module looks like out of the car? I'm trying to see exactly what the other connection looks like and where it is...I think its the pump motor connector that Im trying to see if it's hooked up or not. Please help! :crying2:

musthunt
09-13-09, 10:49 PM
The big connection on top has a slide lock to hold it in, the one on the bottom has a locking tab. Not sure what lights will be on if the bottom ones not plugged in. I replaced mine myself, but didnt think to take pictures.

BossLady
09-20-09, 10:39 PM
The big connection on top has a slide lock to hold it in, the one on the bottom has a locking tab. Not sure what lights will be on if the bottom ones not plugged in. I replaced mine myself, but didnt think to take pictures.

I had a feeling it was a slide lock...do you think that would make it not work? If it wasn't slid in there..cause it just wiggles freely. I tried taking the battery etc apart and unfortunately to really be able to get to it I think Im going to have to take off the radiator hose. May as well try it out cause I really want those damn lights to go off!

Black02SLPSS
09-22-09, 01:56 AM
I had a feeling it was a slide lock...do you think that would make it not work? If it wasn't slid in there..cause it just wiggles freely. I tried taking the battery etc apart and unfortunately to really be able to get to it I think Im going to have to take off the radiator hose. May as well try it out cause I really want those damn lights to go off!

Ya if its not making a good connection it sure could set those lights off. I would get that secured and check back in with us

Greg Zeboray
11-07-09, 07:11 PM
BossLady, in addition to the ABS , TC, and check engine lights, and speedo failure, does your power steering sometimes go out? I an having the same problem.

Also, does the ABS, TC, and speedo issue sometimes go away and then come back? It can be in the middle of driving to when I start it. Very strange!