: Problems with radio/navigation.... NO display after changing buttons



rathershort
08-24-09, 11:25 PM
i have a 2004 escalade. It has the in dash radio/navigation. GM# 15204335.

The buttons were worn so i ordered new ones. I install the new buttons, reconnect the ribbon connection and snap the face back on. At first i had no radio, no LCD, and no buttons worked. but the button lights did work. The next morning i go out and i'm getting sound, just no LCD. No backlight (on the LCD) or anything... the screen looks like it was powered off. BUT now all the buttons seem to work, including the steering wheel buttons. The only button that does not work is the MAP CD eject button.

MY question is, is it possible that when i had the battery disconnected something got reset and i just need to get it reprogrammed? What else could it be? Thanks for the help in advance.

smelly$cat
08-25-09, 06:46 PM
New buttons? I could use some of those on my stock nav deck. Dealer? How much did you pay? Easy to swap out? Sorry I don't have any ideas on your problem.....

nathanjax
08-25-09, 10:46 PM
i have a 2004 escalade. It has the in dash radio/navigation. GM# 15204335.

The buttons were worn so i ordered new ones. I install the new buttons, reconnect the ribbon connection and snap the face back on. At first i had no radio, no LCD, and no buttons worked. but the button lights did work. The next morning i go out and i'm getting sound, just no LCD. No backlight (on the LCD) or anything... the screen looks like it was powered off. BUT now all the buttons seem to work, including the steering wheel buttons. The only button that does not work is the MAP CD eject button.

MY question is, is it possible that when i had the battery disconnected something got reset and i just need to get it reprogrammed? What else could it be? Thanks for the help in advance.


The only thing I can think of is you didn't secure the ribbon in correctly. I have done this 3 times to mine to swap out buttons (including today) and everything has been smooth. I'm not sure what else could have gotten messed up with just taking the face off. If that's not it, no idea. Sorry...




New buttons? I could use some of those on my stock nav deck. Dealer? How much did you pay? Easy to swap out? Sorry I don't have any ideas on your problem.....

ebay search navigation buttons or go here... http://www.replacementradios.com/ I just had to swap out 2 buttons today. They take 5 minutes to swap out. Pull thee radio. unclip the face. Pull the ribbon from the radio (leave it connected to the face) 4 SMALL bolts (3.5mm i think) swap buttons, reverse order to put back together.

smelly$cat
08-26-09, 11:37 AM
Interesting! My button's are not too bad, but, they are showing some wear. I see a "buy it now" set on ebay for 85.

I spent a few min on the link you posted below, but, couldn't find the buttons. Can you tell me what section from the menu on the left to focus on?

Thanks man! :thumbsup:


ebay search navigation buttons or go here... http://www.replacementradios.com/ I just had to swap out 2 buttons today. They take 5 minutes to swap out. Pull thee radio. unclip the face. Pull the ribbon from the radio (leave it connected to the face) 4 SMALL bolts (3.5mm i think) swap buttons, reverse order to put back together.[/QUOTE]

nathanjax
08-26-09, 07:29 PM
If yours is the non touchscreen http://replacementradios.com/product_info.php?cPath=290_320&products_id=901

If yours is the touchscreen http://replacementradios.com/product_info.php?cPath=290_320&products_id=932

smelly$cat
08-26-09, 07:33 PM
Sweet man. Thanks! Adding this to my project punch list. :2thumbs:


If yours is the non touchscreen http://replacementradios.com/product_info.php?cPath=290_320&products_id=901

If yours is the touchscreen http://replacementradios.com/product_info.php?cPath=290_320&products_id=932

CadillacPRH
09-13-09, 04:22 AM
I just ran into the same exact problem. Did you find a solution?

I am hoping that doing something like disconnecting the battery will solve the problem.

CadillacPRH
09-13-09, 04:44 PM
Well, pulling the fuse for the radio did not help at all.

I did a lot of searches, but I can't find anything with any info on what to do when the screen doesn't come back on.

Any idea anyone???

kru
05-17-10, 10:50 AM
Don't know if you figured it out or not but I see the following note in those ads:

"Whatever you do, do NOT attempt to replace these buttons with the radio still plugged in. COMPLETELY REMOVE THE RADIO FROM THE VEHICLE. Your radio has your VIN assigned in memory. It will work without programming once you plug it back in. If you attempt to replace the buttons with the radio still plugged in, you can VERY easily fry your radio. These radios cost several hundred dollars. Do your wallet a favor and do NOT attempt the button replacement while the radio is plugged in!!"

Seems like that could explain your problems, because you didn't mention anything about removing your radio. Just unplugging the ribbon cable.

vincent c
07-05-10, 12:04 PM
has anyone ever figured out this problem. It just happened to me and I wish I would have read this info first I would have never done it. This is driving me insane because I was so careful not to do anything wrong. I have no screen but I have a radio I can change the channels. PLEASE HELP!!!

nathanjax
07-05-10, 02:31 PM
has anyone ever figured out this problem. It just happened to me and I wish I would have read this info first I would have never done it. This is driving me insane because I was so careful not to do anything wrong. I have no screen but I have a radio I can change the channels. PLEASE HELP!!!

There's a ribbon on the right side that attaches the screen to the rest of the radio. be sure that it's not pulled out.

vincent c
07-05-10, 11:19 PM
I have tried everything I cleaned it with alcohol thinking it wasnt making contact nothing seems to work. But thanks for the reply. I disconnected the battery again for a few hours to day thinking it would reset something but nothing.

vincent c
07-09-10, 09:21 PM
Well this is just a little piece of advice I had my radio checked out today and it cant be fixed. I dont know what I could have done to damage it but my advice is dont change the worn buttons on you radio. Now it will cost me about 600.00 to replace it.

Trulytex
08-23-11, 11:02 PM
I guess there is still no definite answer to this thread. I am having the same problem after changing out the buttons a few days ago, except mine worked fine for about 3 days and then suddenly today my screen started flashing on & off. If I wiggle the joystick in the bottom left hand corner it will come back on for a minute or few. I disconnected the ribbon cable from the face, not the radio when I changed out my buttons. I can't see how that could be a problem because it has a disconnect clip. I will check the cable again and make sure it is secure. And I WILL post the results. I have noticed that this forum is weak on people posting results after getting a problem solved....

Trulytex
08-24-11, 11:19 PM
Radio is now Fried! Display won't light up at all and the radio functions are dead. Searched E-bay for used units and they range from $525-$699 (not including shipping) and they all showed plenty signs of wear. I decided to give my local Chevy dealer a call for the heck of it. The parts guy at the dealership gave me a price of $550 (My family has been dealing with this dealership for 45 years and the parts guy always gives me a break) for a factory reconditioned unit with a 12 month warranty and it will be here tomorrow! And he won't charge me the $95 to program the radio to my Escalade. This will be basically a New Unit as opposed to a 7-8 year unit with worn buttons and no warranty. Not a real difficult decission.

Trulytex
08-24-11, 11:23 PM
And take my advice. Before you remove your radio and change your buttons - *Unhook your Battery Cables First* :mad:

Caddy2004X
02-13-13, 01:04 AM
Did everyone with this issue unplug the unit fron the truck? I want to change out my buttons as well, But U have a backup DVD player to install. I can use my Android as a Nav.