: Fuse block covered by wires?



MudAnt
08-20-09, 09:24 PM
I'm trying to get to the fuse block on my 86 FWB, but there seems to be a large amount of wires and such blocking all but the bottom few fuses. Here is a picture:

http://marcdegrandpre.com/images/86%20FWB/IMG_1861.JPG

They are very stiff wires and they're connected to that gray box which is bolted in place.
Is this the way it's supposed to be? Maybe someone did some re-wiring under there and didn't bother to think about access to the fuse block?

jayoldschool
08-20-09, 10:33 PM
Do you have an alarm/keyless/remote starter?

MudAnt
08-20-09, 10:52 PM
It's just the factory alarm, nothing else.

77CDV
08-20-09, 11:24 PM
That all looks factory. I'd disconnect the pink and blue male-female connectors on the left side, then unbolt the grey box and drop it out of the way. That should allow free access to the fuse block. Remember that this was designed in 1977, when a lot of the electronics on your car weren't yet present. Looks like they just added on to what was there rather than redesign for logical access. BTW, why is that black Bosch box floating free? It looks like it ought to be bolted to the firewall somewhere.

sven914
08-20-09, 11:56 PM
BTW, why is that black Bosch box floating free?

Because it's Bosch...

It was probably rejected it like a bad kidney.

jayoldschool
08-20-09, 11:59 PM
I believe my 81 has the same relay, loose like that...

MudAnt
08-21-09, 02:07 AM
Thanks for the suggestions, I'll try it out tomorrow.